hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Espino <esp...@apache.org>
Subject Re: RHEL/CentOS 7 plperl build issue when using configure with "--with-perl" option
Date Tue, 17 Jan 2017 03:05:56 GMT
Thanks Hongxu for the validation.  I have submitted PR
https://github.com/apache/incubator-hawq/pull/1091 for this issue. Once
reviewed, I will include it in the Apache 2.1.0.0-incubating RC2 release.
Any volunteers to review this PR?

Thanks,
-=e

On Mon, Jan 16, 2017 at 5:55 PM, Ma Hongxu <interma@outlook.com> wrote:

> I found the same problem on CentOS7, and the patch of your mentioned can
> fix it. The patch also worked well on MacOS.
>
> Thanks, ed.
>
> 在 16/01/2017 15:57, Ed Espino 写道:
> Has anyone encountered the following build error on RHEL/CentOS 7 build
> issue when using configure with "--with-perl" option?
>
> make[3]: Entering directory `/home/centos/apache-hawq-src-
> 2.1.0.0-incubating/src/pl/plperl'
> "/usr/bin/perl" ./text2macro.pl<http://text2macro.pl>
> --strip='^(\#.*|\s*)$' plc_perlboot.pl<http://plc_perlboot.pl>
> plc_trusted.pl<http://plc_trusted.pl> > perlchunks.h
> "/usr/bin/perl" plperl_opmask.pl<http://plperl_opmask.pl> plperl_opmask.h
> "/usr/bin/perl" /usr/share/perl5/ExtUtils/xsubpp -typemap
> /usr/share/perl5/ExtUtils/typemap SPI.xs >SPI.c
> "/usr/bin/perl" /usr/share/perl5/ExtUtils/xsubpp -typemap
> /usr/share/perl5/ExtUtils/typemap Util.xs >Util.c
> Can't open perl script "/usr/share/perl5/ExtUtils/xsubpp": No such file
> or directory
> Can't open perl script "/usr/share/perl5/ExtUtils/xsubpp": No such file
> or directory
> make[3]: *** [SPI.c] Error 2
> make[3]: *** Deleting file `SPI.c'
> make[3]: *** Waiting for unfinished jobs....
> make[3]: *** [Util.c] Error 2
> make[3]: *** Deleting file `Util.c'
> make[3]: Leaving directory `/home/centos/apache-hawq-src-
> 2.1.0.0-incubating/src/pl/plperl'
> make[2]: *** [all] Error 1
> make[2]: Leaving directory `/home/centos/apache-hawq-src-
> 2.1.0.0-incubating/src/pl'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/home/centos/apache-hawq-src-
> 2.1.0.0-incubating/src'
> make: *** [all] Error 2
>
> I also have found a fix for this which was backported from PostgreSQL to
> the Greenplum DB master branch a year ago by Heikki Linnakangas<
> https://github.com/hlinnaka> (Original PostgreSQL committer Andrew
> Dunstan <andrew@dunslane.net<mailto:andrew@dunslane.net>>):
>
> https://github.com/greenplum-db/gpdb/commit/f493756a5ac8a90ff1d5e3b84f38a1
> 53c9f80b9c#diff-97d34e5e3684082069b6c85876df9107
>
> A have added a patch (attached) to the email for review.  It corrects the
> build issue identified above. When the Apache JIRA system is back online, I
> will be creating a JIRA and corresponding pull request with this patch.
>
> -=e
> --
> Ed Espino
> espino@apache.org<mailto:espino@apache.org>
>
>
> --
> Regards,
> Hongxu.
>



-- 
*Ed Espino*
*espino@apache.org <espino@apache.org>*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message