hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hong Wu <xunzhang...@gmail.com>
Subject Re: Has anyone meet this problem before for running hawq: libxml doesn't match
Date Wed, 14 Dec 2016 13:56:10 GMT
Oh, if this works, I think "brew link libxml2" will also work.

Hong

2016-12-14 21:35 GMT+08:00 Lili Ma <lilima@apache.org>:

> Thanks Paul and Kyle for your help!
>
> It's due to incompatible version.
>
> I brew installed libxml and included the installed binary in class path,
> and resolved this problem :)
> export PATH=/usr/local/opt/libxml2/bin:$PATH
>
> Thanks
> Lili
>
> 2016-12-01 23:05 GMT+08:00 Kyle Dunn <kdunn@pivotal.io>:
>
> > Hi Lili -
> >
> > I'm able to run configure on my Mac (Sierra) successfully. It looks like
> > libxml2 was installed manually at some point into the /opt/local prefix
> and
> > PATH updated to search there first instead of using the one in /usr/bin.
> > Although, it looks like the same version in both places on mine.
> >
> > checking for xml2-config... /opt/local/bin/xml2-config
> > checking for libxml - version >= 2.7.6... yes (version 2.9.4)
> >
> >
> > Hope this helps.
> >
> > -Kyle
> >
> > On Wed, Nov 30, 2016 at 9:07 PM Paul Guo <paulguo@gmail.com> wrote:
> >
> > > You may check the log for some clues. Besides, I just quickly check the
> > > configure file, the related checking code in rather simple, you could
> > have
> > > a quick debugging.
> > >
> > > 2016-11-30 22:53 GMT+08:00 Lili Ma <lilima@apache.org>:
> > >
> > > > Hi All,
> > > >
> > > > Has anyone meet this problem when trying to configure or make hawq
> > source
> > > > code on Mac?
> > > >
> > > > checking for xml2-config... /usr/bin/xml2-config
> > > > checking for libxml - version >= 2.7.6... *** libxml header files
> > > (version
> > > > 2.9.2) do not match
> > > > *** xml2-config (version 2.9.0)
> > > > no
> > > > configure: error: libxml2 is required.
> > > > Check config.log for details. It is possible the compiler isn't
> looking
> > > in
> > > > the proper directory.
> > > > make: *** [config.status] Error 1
> > > >
> > > > If yes, could you please advise?
> > > >
> > > > Thanks
> > > > Lili
> > > >
> > >
> > --
> > *Kyle Dunn | Data Engineering | Pivotal*
> > Direct: 303.905.3171 <3039053171> | Email: kdunn@pivotal.io
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message