hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shivram Mani <shivram.m...@gmail.com>
Subject Re: Hadoop dependencies error when install pxf-service
Date Mon, 19 Dec 2016 19:45:39 GMT
PXF in its core doesn't have any strict dependency on a particular
distribution of hadoop as long as the version requirement is met.
Please do file an improvement ticket against HAWQ
https://issues.apache.org/jira/browse/HAWQ/ under component PXF requesting
a change in this regard. We shouldn't have a strict check to see if the
distribution is 'hdp' or 'phd' (pxf/build.gradle has this check)

Meanwhile, if you still need to generate the pxf-service rpm, you can
simply set the 'hd' environment variable to 'hdp' as a workaround and
update the contents in src/main/resources/pxf-privatehdp.classpath to be
corresponding to your hadoop library paths.
You an now successfully build the rpm.


On Mon, Dec 19, 2016 at 4:58 AM, 胡晓 <huxiao64@icloud.com> wrote:

> Should I need to change the classpath of Hadoop distribution in
> build.gradle. I notice that the Hadoop distribution must be hdp or phd
>
> 发自我的 iPhone
>
> > 在 2016年12月19日,20:04,胡晓 <huxiao64@icloud.com> 写道:
> >
> > Hi,community
> >
> >  when I want to install pxf service with rpm after building pxf from
> source.
> > I run: rpm -ivh pxf-service.xxxx.rpm
> > I meet errors:
> >
> > Hadoop >= 2.7.1 is needed by pxf-service
> > Hadoop-hdfs >2.7.1 is need by pxf-service
> >
> > But I have installed hadoop 2.7.2 of open source version.
> >
> > Could you help me install pxf?
> >
> > Thanks,
> > Xiao
> >
> > 发自我的 iPhone
>



-- 
shivram mani

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message