hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hong Wu <xunzhang...@gmail.com>
Subject Re: Issues building Apache HAWQ on Redhat Linux.
Date Wed, 31 Aug 2016 03:33:28 GMT
Hi raman,

It seems that prefix you use has some conflict.

gcc -O3 -std=gnu99  -Wall -Wmissing-prototypes -Wpointer-arith
-Wendif-labels -Wformat-security -fno-strict-aliasing -fwrapv
-fno-aggressive-loop-optimizations  -I/usr/include/libxml2
-I../../src/port -DFRONTEND -I../../src/include -D_GNU_SOURCE
-*I/root/incubator-hawq/depends/libhdfs3/build/install/usr/local/hawq/**include*
-I/root/incubator-hawq/depends/libyarn/build/install/usr/local/hawq/include
 -c -o copydir.o copydir.c

According to your given message above, the prefix is '/*usr/local/hawq*'
while actually you specified the prefix with 'opt/hawq', there must be
something inconsistency. The root course might be you did not "make
distclean" before another second configuration.

Hope this help.

Best
Hong



2016-08-30 22:36 GMT+08:00 raman bedi <ramanbedi1989@gmail.com>:

> Hi Sir/Madam,
> I have been trying to build Apache HAWQ on Redhat Linux. The third party
> dependencies compile successfully and I am getting errors from the source
> (src) compilation. Please have a look at this link
> <http://stackoverflow.com/questions/39217467/hawq-installation-on-redhat>
> for the details of the issue. Please let me know if it's a build defect or
> something that I can resolve on my end as I am unable to find any
> assistance on the same.
>
> Regards,
> Raman Bedi
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message