hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Radar Da lei <r...@pivotal.io>
Subject Re: Rpmbuild Hawq Failed
Date Thu, 02 Jun 2016 13:22:03 GMT
It requires these because you defined the requirements in your rpm spec
file. If you want to deal dependencies by yourself, then you can remove
these requirements and add 'AutoReqProv:    no' to your spec file.

To deal these dependencies by yourself, you can use yum to install all the
dependencies if you use centos/rhel 7.x.

For centos/rhel 6.x, yum can't install all the dependencies, you have to
manually build and install them, e.g download&build&install
boost/protobuf/curl/thrift.

For all HAWQ's dependences you can refer to:
https://cwiki.apache.org/confluence/display/HAWQ/Build+and+Install

Thanks.


Regards,
Radar

On Thu, Jun 2, 2016 at 5:27 PM, yuansong <yyuansong@126.com> wrote:

>
>
> Hi, I want to rpmbuild hawq. I make the rpm, but i want to install it and
> report this:
> # rpm -ivh hawq-2.0.0.0-1.el6.x86_64.rpm
> error: Failed dependencies:
> /bin/ksh is needed by hawq-2.0.0.0-1.el6.x86_64
> bsh-utils is needed by hawq-2.0.0.0-1.el6.x86_64
> hadoop-hdfs is needed by hawq-2.0.0.0-1.el6.x86_64
> libboost_date_time.so.1.59.0()(64bit) is needed by
> hawq-2.0.0.0-1.el6.x86_64
> libboost_system.so.1.59.0()(64bit) is needed by hawq-2.0.0.0-1.el6.x86_64
> libc.so.6(GLIBC_2.14)(64bit) is needed by hawq-2.0.0.0-1.el6.x86_64
> libprotobuf.so.8()(64bit) is needed by hawq-2.0.0.0-1.el6.x86_64
> libthrift-0.9.2.so()(64bit) is needed by hawq-2.0.0.0-1.el6.x86_64
> Could somebody help me?  Where I can find the Hawq rpmbuild spec file ?
> May Somebody offer his rpmbuild spec file? Thanks !
>
>
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message