hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pravin Rao <pravra...@gmail.com>
Subject Issues initializing HAWQ cluster
Date Tue, 17 May 2016 20:58:59 GMT
Hi all,

I have a HDP 2.4 single-node VM running on CentOS 6.7.  I recently built
and installed Apache HAWQ, but I'm not able to initialize the cluster.
When I first tried to run 'hawq init cluster', I received the following
error:

hawq_init:hawqcluster-01:gpadmin-[INFO]:-Start hawq master failed

hawq_init:hawqcluster-01:gpadmin-[WARNING]:-pg_ctl: PID file
"/data/hawq/master/postmaster.pid" does not exist

hawq_init:hawqcluster-01:gpadmin-[ERROR]:-Master init failed, exit



I ran the command again a few days later and I got a different error:

hawq_init:hawqcluster-01:gpadmin-[INFO]:-Prepare to do 'hawq init'

hawq_init:hawqcluster-01:gpadmin-[INFO]:-You can find log in:

hawq_init:hawqcluster-01:gpadmin-[INFO]:-/home/gpadmin/hawqAdminLogs/hawq_init_20160517.log

hawq_init:hawqcluster-01:gpadmin-[INFO]:-GPHOME is set to:

hawq_init:hawqcluster-01:gpadmin-[INFO]:-/usr/local/hawq

hawq_init:hawqcluster-01:gpadmin-[INFO]:-Init hawq with args: ['init',
'cluster']

hawq_init:hawqcluster-01:gpadmin-[INFO]:-No standby host configured, skip it

hawq_init:hawqcluster-01:gpadmin-[INFO]:-Check if hdfs path is available

hawq_init:hawqcluster-01:gpadmin-[INFO]:-1 segment hosts defined

hawq_init:hawqcluster-01:gpadmin-[INFO]:-Set
default_hash_table_bucket_number as: 6

hawq_init:hawqcluster-01:gpadmin-[ERROR]:-sync hawq-site.xml failed.

hawq_init:hawqcluster-01:gpadmin-[ERROR]:-Set
default_hash_table_bucket_number



I tried changing the value of default_hash_table_bucket_number in the
hawq-site.xml file but I keep getting the same error.  Any ideas on what I
might be missing?

Thanks!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message