hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruilong Huo <r...@pivotal.io>
Subject Re: Strange error during the db initialization
Date Fri, 11 Mar 2016 02:26:22 GMT
Hi Konstantin,

You need to enable correct hawq environment (source the right
greenplum_path.sh) to make it use corresponding psql.

Best regards,
Ruilong Huo

On Fri, Mar 11, 2016 at 10:20 AM, Konstantin Boudnik <cos@apache.org> wrote:

> Keep on digging here....
>
> I spent a bit of time trying to run
>   % psql -d postgres
>
> because I was hitting the error where psql couldn't bind to PGSQL socket
> locally, so I had to create
>     ln -s /tmp/.s.PGSQL.5432 /var/run/postgresql/.s.PGSQL.5432
>
> Now, the client is able to connect to the server, but I am getting this
> psql (9.2.15, server 8.2.15)
> WARNING: psql version 9.2, server version 8.2.
>          Some psql features might not work.
>
> which is quite weird, considering that I have built everything from the
> current master's HEAD. I see that server version is hardcoded everywhere,
> and
> the client code is checked into the code base. Is it possible these version
> were intentionally made different? Any ideas what could be causing these
> discrepancies?
>
> Thanks
>   Cos
>
> On Thu, Mar 10, 2016 at 01:26PM, Konstantin Boudnik wrote:
> > Ah, indeed - sysctl changed helped! Thanks for the good piece of the
> info.
> >
> > Cos
> >
> > On Thu, Mar 10, 2016 at 04:20PM, Lei Chang wrote:
> > > Hi Konstantin,
> > >
> > > I think it is possible due to system configurations, I just added an
> > > section about "system configuration" on the build and install page.
> you can
> > > have a try.
> > >
> > > https://cwiki.apache.org/confluence/display/HAWQ/Build+and+Install
> > >
> > > Cheers
> > > Lei
> > >
> > >
> > > On Thu, Mar 10, 2016 at 1:36 PM, Konstantin Boudnik <cos@apache.org>
> wrote:
> > >
> > > > Guys,
> > > >
> > > > I am seeing the following debug output while running initial boot
> sequence:
> > > >
> > > >   bash-4.2$ /usr/lib/hawq/bin/postgres -d 5 --boot -x0 -F -c
> > > > max_connections=1280 -c shared_buffers=4000 -c max_fsm_pages=200000 <
> > > > "/dev/null"
> > > >
> > > >   2016-03-10 05:34:31.445003
> > > >
> GMT,,,p32521,th-908068352,,,,0,,,seg-10000,,,,,"FATAL","42601","--boot
> > > >   requires a value",,,,,,,,"PostmasterMain","postmaster.c",1023,
> > > >   2016-03-10 05:34:31.445777
> > > >
> GMT,,,p32521,th-908068352,,,,0,,,seg-10000,,,,,"DEBUG3","00000","shmem_exit(1):
> > > >   0 callbacks to make",,,,,,,,"shmem_exit","ipc.c",195,
> > > >   2016-03-10 05:34:31.446467
> > > >
> GMT,,,p32521,th-908068352,,,,0,,,seg-10000,,,,,"DEBUG3","00000","proc_exit(1):
> > > >   0 callbacks to make",,,,,,,,"proc_exit_prepare","ipc.c",167,
> > > >   2016-03-10 05:34:31.447147
> > > >
> GMT,,,p32521,th-908068352,,,,0,,,seg-10000,,,,,"DEBUG3","00000","exit(1)",,,,,,,,"proc_exit","ipc.c",132,
> > > >
> > > >
> > > > Can't figure out what's missing. Would appreciate any pointers.
> > > > Thanks in advance,
> > > >   Cos
> > > >
> > > >
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message