hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Feng Tian <ft...@vitessedata.com>
Subject Re: hawq init?
Date Sun, 04 Oct 2015 05:48:53 GMT
sorry, so, one seg per node.   does the node get defined in
hawq-site.xml?    just add nodes there?
On Oct 3, 2015 10:46 PM, "Feng Tian" <ftian@vitessedata.com> wrote:

> interesting.   what if i have two physical nodes?
>
> and, how can i control the number of forked processes?   do i have to
> believe planner will pickup the right number?   any pointer to design
> and/or implementation?
>
> thanks,
> On Oct 3, 2015 8:02 PM, "Zhanwei Wang" <zwang@pivotal.io> wrote:
>
>> Hi Feng
>>
>> Unlike Greenplum Database and HAWQ 1.x. Apache HAWQ will init only one
>> segment on each node.
>>
>> But Apache HAWQ can fork many work processes on one segment to execute the
>> plan. The number of work processes depends on the query and plan.
>>
>> Best Regards
>> Zhanwei Wang
>>
>>
>> On Sun, Oct 4, 2015 at 12:39 AM, Feng Tian <ftian@vitessedata.com> wrote:
>>
>> > Hi,
>> >
>> > Hawq init cluster on my box works great, but it only creates one
>> segment.
>> > How can I init a cluster of say, two segments?  Which config file
>> should I
>> > edit?
>> >
>> > Tried gpinitsystem (does not work), tried google but cannot find much
>> info.
>> >
>> > Thanks,
>> >
>>
>>
>>
>> --
>> Best Regards
>> ----------
>>
>> Zhanwei Wang
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message