harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillermo Cabrera <gcab...@us.ibm.com>
Subject [testing] Harmony6 Error: java.text.ParseException: [[Fatal Error]
Date Fri, 15 Oct 2010 20:38:18 GMT


Hello:

Using Harmony 6 (rev. 1022139) built on a SUSE Linux Enterprise Server 11
using gcc version 4.3.2. I am currently trying to build the Apache Hadoop
component (v. 0.21.0) using Harmony. Currently running into an issue
relating to parsing an xml file. The error thrown is

 java.text.ParseException: [[Fatal Error] ivy.xml:1:20: The version is
required in the XML declaration in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml

The file in question does indeed have the version attribute (ex. <?xml
version="1.0"?>). An initial conjecture discards this being an Apache
Hadoop or Apache Ivy related issue, as this error is not present when
building Hadoop using IBM JRE 1.6.0  or SUN JVM 1.6.0_14. I attach the
complete debug information that ant displays.

ivy-resolve-test:
[ivy:resolve] [[Fatal Error] ivy.xml:1:20: The version is required in the
XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
[ivy:resolve] ]

BUILD FAILED
/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml:741: The
following error occurred while executing this line:
/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml:1626: syntax
errors in ivy file: java.text.ParseException: [[Fatal Error] ivy.xml:1:20:
The version is required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml


[ivy:resolve] parameter found as attribute value: ivy.configurations=test
[ivy:resolve] parameter found as ivy variable:
ivy.resolve.default.type.filter=*
[ivy:resolve] parameter found as ivy variable: ivy.dep.file=ivy.xml
[ivy:resolve] using ivy parser to parse
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
Resource org/apache/ivy/plugins/parser/xml/ivy.xsd loaded from ant loader
[ivy:resolve] [[Fatal Error] ivy.xml:1:20: The version is required in the
XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
[ivy:resolve] ]
  [antcall]
Exiting /home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml.

BUILD FAILED
/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml:741: The
following error occurred while executing this line:
/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml:1626: syntax
errors in ivy file: java.text.ParseException: [[Fatal Error] ivy.xml:1:20:
The version is required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
]
	at org.apache.tools.ant.ProjectHelper.addLocationToBuildException
(ProjectHelper.java:508)
	at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:418)
	at org.apache.tools.ant.taskdefs.CallTarget.execute
(CallTarget.java:105)
	at org.apache.tools.ant.UnknownElement.execute
(UnknownElement.java:288)
	at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
	at java.lang.reflect.Method.invoke(Method.java:316)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute
(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:357)
	at org.apache.tools.ant.Target.performTasks(Target.java:385)
	at org.apache.tools.ant.Project.executeSortedTargets
(Project.java:1337)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets
(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
	at org.apache.tools.ant.Main.runBuild(Main.java:758)
	at org.apache.tools.ant.Main.startAnt(Main.java:217)
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
Caused
by: /home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml:1626:
syntax errors in ivy file: java.text.ParseException: [[Fatal Error]
ivy.xml:1:20: The version is required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
]
	at org.apache.ivy.ant.IvyResolve.doExecute(IvyResolve.java:314)
	at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
	at org.apache.tools.ant.UnknownElement.execute
(UnknownElement.java:288)
	at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
	at java.lang.reflect.Method.invoke(Method.java:316)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute
(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:357)
	at org.apache.tools.ant.Target.performTasks(Target.java:385)
	at org.apache.tools.ant.Project.executeSortedTargets
(Project.java:1337)
	at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets
(SingleCheckExecutor.java:38)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
	at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
	at org.apache.tools.ant.taskdefs.CallTarget.execute
(CallTarget.java:105)
	... 15 more
Caused by: java.text.ParseException: [[Fatal Error] ivy.xml:1:20: The
version is required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
]
	at org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser
$AbstractParser.checkErrors(AbstractModuleDescriptorParser.java:89)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser
$Parser.parse(XmlModuleDescriptorParser.java:272)
	at
org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.parseDescriptor
(XmlModuleDescriptorParser.java:112)
	at
org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser.parseDescriptor
(AbstractModuleDescriptorParser.java:48)
	at org.apache.ivy.core.resolve.ResolveEngine.resolve
(ResolveEngine.java:185)
	at org.apache.ivy.Ivy.resolve(Ivy.java:502)
	at org.apache.ivy.ant.IvyResolve.doExecute(IvyResolve.java:244)
	at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
	... 27 more
--- Nested Exception ---
/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/build.xml:1626: syntax
errors in ivy file: java.text.ParseException: [[Fatal Error] ivy.xml:1:20:
The version is required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
]
	at org.apache.ivy.ant.IvyResolve.doExecute(IvyResolve.java:314)
	at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
	at org.apache.tools.ant.UnknownElement.execute
(UnknownElement.java:288)
	at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
	at java.lang.reflect.Method.invoke(Method.java:316)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute
(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:357)
	at org.apache.tools.ant.Target.performTasks(Target.java:385)
	at org.apache.tools.ant.Project.executeSortedTargets
(Project.java:1337)
	at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets
(SingleCheckExecutor.java:38)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
	at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
	at org.apache.tools.ant.taskdefs.CallTarget.execute
(CallTarget.java:105)
	at org.apache.tools.ant.UnknownElement.execute
(UnknownElement.java:288)
	at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
	at java.lang.reflect.Method.invoke(Method.java:316)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute
(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:357)
	at org.apache.tools.ant.Target.performTasks(Target.java:385)
	at org.apache.tools.ant.Project.executeSortedTargets
(Project.java:1337)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets
(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
	at org.apache.tools.ant.Main.runBuild(Main.java:758)
	at org.apache.tools.ant.Main.startAnt(Main.java:217)
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
Caused by: java.text.ParseException: [[Fatal Error] ivy.xml:1:20: The
version is required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
]
	at org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser
$AbstractParser.checkErrors(AbstractModuleDescriptorParser.java:89)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser
$Parser.parse(XmlModuleDescriptorParser.java:272)
	at
org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.parseDescriptor
(XmlModuleDescriptorParser.java:112)
	at
org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser.parseDescriptor
(AbstractModuleDescriptorParser.java:48)
	at org.apache.ivy.core.resolve.ResolveEngine.resolve
(ResolveEngine.java:185)
	at org.apache.ivy.Ivy.resolve(Ivy.java:502)
	at org.apache.ivy.ant.IvyResolve.doExecute(IvyResolve.java:244)
	at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
	... 27 more
--- Nested Exception ---
java.text.ParseException: [[Fatal Error] ivy.xml:1:20: The version is
required in the XML declaration. in
file:/home/harmony/Hadoop-Versions/hadoop-0.21.0/common/ivy.xml
]
	at org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser
$AbstractParser.checkErrors(AbstractModuleDescriptorParser.java:89)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser
$Parser.parse(XmlModuleDescriptorParser.java:272)
	at
org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.parseDescriptor
(XmlModuleDescriptorParser.java:112)
	at
org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser.parseDescriptor
(AbstractModuleDescriptorParser.java:48)
	at org.apache.ivy.core.resolve.ResolveEngine.resolve
(ResolveEngine.java:185)
	at org.apache.ivy.Ivy.resolve(Ivy.java:502)
	at org.apache.ivy.ant.IvyResolve.doExecute(IvyResolve.java:244)
	at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
	at org.apache.tools.ant.UnknownElement.execute
(UnknownElement.java:288)
	at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
	at java.lang.reflect.Method.invoke(Method.java:316)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute
(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:357)
	at org.apache.tools.ant.Target.performTasks(Target.java:385)
	at org.apache.tools.ant.Project.executeSortedTargets
(Project.java:1337)
	at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets
(SingleCheckExecutor.java:38)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
	at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
	at org.apache.tools.ant.taskdefs.CallTarget.execute
(CallTarget.java:105)
	at org.apache.tools.ant.UnknownElement.execute
(UnknownElement.java:288)
	at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
	at java.lang.reflect.Method.invoke(Method.java:316)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute
(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:357)
	at org.apache.tools.ant.Target.performTasks(Target.java:385)
	at org.apache.tools.ant.Project.executeSortedTargets
(Project.java:1337)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets
(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
	at org.apache.tools.ant.Main.runBuild(Main.java:758)
	at org.apache.tools.ant.Main.startAnt(Main.java:217)
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)


Regards,
Guillermo
----------------------------------------------
Emerging Internet Technology Group
gcabrer@us.ibm.com
Office: +1-512-973-1973 (T/L: 363-1973)
Mobile: +1-956-522-0988
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message