harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Deakin <oliver.dea...@googlemail.com>
Subject Re: [testing] Java 6 branch results so far
Date Tue, 07 Sep 2010 14:50:15 GMT
  On 07/09/2010 15:14, Mark Hindess wrote:
> In message<201009021351.o82DpAf1032182@d12av03.megacenter.de.ibm.com>,
> Mark Hindess writes:
>> [SNIP]
>>
>> There do seem to be problems though.  Such as, if I run:
>>
>>    java  -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=localhost:9900
-showversion HelloWorld
>>
>> and then attach with:
>>
>>    /ri/jdk/bin/jdb -attach 9900
>>
>> If I enter 'run' at the prompt I see "Hello World" output but then that
>> process hangs.  It wouldn't surprise me if this and the problems you
>> are seeing are related.
>>
>> I see the same behaviour on other recent milestones too.
> Hmm . . . So I tried it again today and I didn't see the behaviour
> on 6.0M2 and 6.0M1.  It turns out if I type 'quit' in jdb before the
> execution has "finished" then I don't get the hang but if the execution
> has "finished" then it hangs.
>
> So I thought this was a regression for a while but it turns out that is
> down to my typing "quit" quicker this morning.  (This may be an instance
> of the socket problem that has an open JIRA where a blocking read is
> not interrupted by a close on a different thread that we don't see when
> GC is still running as USR2 signals are being generated regularly to
> interrupt us.)

I see the same problem with the RI's jdb tool on Windows x86 in M1 and 
M2. In windbg I see the stack trace points to the SelectRead() function 
in JDWP. As you say, it is likely this is caused by a blocking socket 
call being unable to be interruped.

I don't see this problem recreate when debugging with Eclipse or with 
Harmony's jdb tool. I suspect this may be because they send a message 
(maybe VM_DEATH) to the server side to tell it they are exiting, and 
this causes JDWP to shutdown and exit rather than waiting for further 
packets.

> So, I see no regressions on jdwp or indeed java6 generally.  What about
> everyone else who raised issues?  Any regressions/blockers?

I think this was the last issue that I felt might block the java 6 
milestone. The other failures I see are not regressions.

Regards,
Oliver

> -Mark.
>
>
>

-- 
Oliver Deakin
Unless stated otherwise above:
IBM United Kingdom Limited - Registered in England and Wales with number 741598.
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU


Mime
View raw message