harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [build] Fail to fetch depends on AIX ppc 64 machine
Date Tue, 14 Sep 2010 07:47:23 GMT

In message <AANLkTim83ZtVH9CPi3L1aaBV58bw=65LuSPz5ChPw-qC@mail.gmail.com>,
Shi Jun Zhang writes:
>
> Hi guys,
> 
> I try to run "ant fetch-depends" on an AIX ppc 64 machine but get the
> following error message.
> 
> -really-download:
>      [echo] Fetching
> /home/chance/codebase/java5/common_resources/depends/libs/aix.ppc64/icu-3.4/i
> cu-3.4.zip
>       [get] Getting:
> http://svn.apache.org/repos/asf/harmony/standard/depends/libs/aix.ppc64/icu-3
> .4.zip
>       [get] To:
> /home/chance/codebase/java5/common_resources/depends/libs/aix.ppc64/icu-3.4/i
> cu-3.4.zip
>       [get] Error opening connection java.io.FileNotFoundException:
> http://svn.apache.org/repos/asf/harmony/standard/depends/libs/aix.ppc64/icu-3
> .4.zip
>       [get] Error opening connection java.io.FileNotFoundException:
> http://svn.apache.org/repos/asf/harmony/standard/depends/libs/aix.ppc64/icu-3
> .4.zip
>       [get] Error opening connection java.io.FileNotFoundException:
> http://svn.apache.org/repos/asf/harmony/standard/depends/libs/aix.ppc64/icu-3
> .4.zip
>       [get] Can't get
> http://svn.apache.org/repos/asf/harmony/standard/depends/libs/aix.ppc64/icu-3
> .4.zipto
> /home/chance/codebase/java5/common_resources/depends/libs/aix.ppc64/icu-3.4/i
> cu-3.4.zip
> 
> BUILD FAILED
> /home/chance/codebase/java5/build.xml:553: The following error occurred
> while executing this line:
> /home/chance/codebase/java5/drlvm/build.xml:74: The following error occurred
> while executing this line:
> /home/chance/codebase/java5/drlvm/make/depends.xml:46: The following error
> occurred while executing this line:
> /home/chance/codebase/java5/common_resources/make/depends.xml:69: The
> following error occurred while executing this line:
> /home/chance/codebase/java5/common_resources/make/depends.xml:81: The
> following error occurred while executing this line:
> /home/chance/codebase/java5/drlvm/make/vm/vmcore.xml:26: The following error
> occurred while executing this line:
> /home/chance/codebase/java5/common_resources/make/depends.xml:99: The
> following error occurred while executing this line:
> /home/chance/codebase/java5/common_resources/make/depends.xml:170: The
> following error occurred while executing this line:
> /home/chance/codebase/java5/common_resources/make/depends.xml:204: Can't get
> http://svn.apache.org/repos/asf/harmony/standard/depends/libs/aix.ppc64/icu-3.4.zip to
> /home/chance/codebase/java5/common_resources/depends/libs/aix.ppc64/icu-3.4/icu-3.4.zip
> 
> Does someone changed the script recently?

No.

DRLVM has not been ported to AIX PPC64 so fetching the dependencies for
that platform is really a trivial problem with the path you are taking.
If you are planning on porting it then those binaries are quite easy to
build.  There is a description of the process in this JIRA:

  https://issues.apache.org/jira/browse/HARMONY-1676

If you are trying to build for a different VM then you need to
override the vm.dir property on the ant command line.  For example, on
windows/linux x86 to use the IBM VME from developerworks, you'd do:

  ant -Dvm.dir=ibm-v4

Regards,
 Mark.



Mime
View raw message