harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [testing] Java 6 branch results so far
Date Tue, 07 Sep 2010 14:14:05 GMT

In message <201009021351.o82DpAf1032182@d12av03.megacenter.de.ibm.com>,
Mark Hindess writes:
>
> [SNIP]
>
> There do seem to be problems though.  Such as, if I run:
> 
>   java  -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=localhost:9900 -showversion
HelloWorld
> 
> and then attach with:
> 
>   /ri/jdk/bin/jdb -attach 9900
> 
> If I enter 'run' at the prompt I see "Hello World" output but then that
> process hangs.  It wouldn't surprise me if this and the problems you
> are seeing are related.
> 
> I see the same behaviour on other recent milestones too.

Hmm . . . So I tried it again today and I didn't see the behaviour
on 6.0M2 and 6.0M1.  It turns out if I type 'quit' in jdb before the
execution has "finished" then I don't get the hang but if the execution
has "finished" then it hangs.

So I thought this was a regression for a while but it turns out that is
down to my typing "quit" quicker this morning.  (This may be an instance
of the socket problem that has an open JIRA where a blocking read is
not interrupted by a close on a different thread that we don't see when
GC is still running as USR2 signals are being generated regularly to
interrupt us.)

So, I see no regressions on jdwp or indeed java6 generally.  What about
everyone else who raised issues?  Any regressions/blockers?

-Mark.



Mime
View raw message