harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject [testing] jdwp tests hanging
Date Mon, 30 Aug 2010 08:18:36 GMT
I'm trying to run through all the tests ahead of the milestone, but
getting hangs on jdwp tests that are apparently waiting for connections.

Shouldn't they time out after a period? otherwise I have to kill ant and
lose the run.

e.g.
 [junit] Run:
org.apache.harmony.jpda.tests.jdwp.MultiSession.FieldAccessTest.testFieldAccess001
 [junit] ----------------------------------------
 [junit] ATTACH connector kind
 [junit] [SYNC] Binding socket on port: 0
 [junit] [SYNC] Bound socket on port: 3318
 [junit] Attach to: 127.0.0.1:9898
 [junit] Launch: ...
 [junit] Launch process: ...
 [junit] Splitted command line: ...
 [junit] Launched process
 [junit] Start redirectors
 [junit] Redirector started: STDERR
 [junit] Redirector started: STDOUT
 [junit] Started redirectors
 [junit] Launched debuggee process
 [junit] Attaching for JDWP connection
 [junit] STDOUT> Listening for transport dt_socket at address: 9898
 [junit] Established transport connection
 [junit] Established JDWP connection with debuggee VM
 [junit] Received inital VM_INIT event
 [junit] Adjusted VM-dependent type lengths
 [junit] Resumed debuggee VM
 [junit] [SYNC] Accepting socket connection

and again on
org.apache.harmony.jpda.tests.jdwp.MultiSession.ExceptionTest.testException001



Mime
View raw message