harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject Re: Build failed in Hudson: Harmony-1.5-head-linux-x86_64-full-tests #302
Date Sat, 28 Aug 2010 18:22:01 GMT
On 28/Aug/2010 17:35, Oliver Deakin wrote:
>  On 28/08/2010 17:27, Apache Hudson Server wrote:
>> <SNIP>
>>
>> gen-report:
>>       [echo] The test report is
>> in<https://hudson.apache.org/hudson/job/Harmony-1.5-head-linux-x86_64-full-tests/ws/harmony/target/test_report/html/index.html>
>>
> 
> I keep trying to look at the test reports linked in the alerts mails,
> but the links don't seem to have worked for a while. I thought at first
> the workspaces might have just been deleted because they were out of
> date, but this one only came through a few minutes ago. It turns out
> that all the xml test report files can be found at [1] still, it just
> appears that the html directory hasn't been generated. Anyone know why
> the html reports aren't being generated?

the Hudson command line is
 ant -f harmony/build.xml -Dgen.report=false
-Dexclude.module=awt,beans,swing test

Note the gen.report=false property.

The Hudson plugin parses the JUnit results directly, so you get the same
info via

https://hudson.apache.org/hudson/view/Harmony/job/Harmony-1.5-head-linux-x86_64-full-tests/302/testReport/

Regards,
Tim



> [1]
> https://hudson.apache.org/hudson/job/Harmony-1.5-head-linux-x86_64-full-tests/ws/harmony/target/test_report/
> 
> 

Mime
View raw message