harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regis <xu.re...@gmail.com>
Subject Re: svn commit: r959837 - /harmony/enhanced/java/trunk/classlib/modules/portlib/src/main/native/a2e/unix/atoe.c
Date Fri, 02 Jul 2010 07:32:41 GMT
On 2010-07-02 15:06, Mark Hindess wrote:
>
> Please can we use idiomatic array syntax rather than pointer arithmetic.
> That is, instead of:
>
>    *(ebcdicArgv+i) = strdup(a2e_string(argv[i]));
>    *(ebcdicArgv + size) = NULL;
>
> use:
>
>    ebcdicArgv[i] = strdup(a2e_string(argv[i]));
>    ebcdicArgv[size] = NULL;
>
> This is more consistent (for example with the use of argv[i] on the some
> of the lines).
>
> I've noticed this in a few other places and it makes code unnecessarily
> difficult to read.
>
> Thanks,
>   Mark.
>

I do not have strange opinions on this things, well making code more readable is 
always valuable, so fixed in r959887. And also some minor fixes in r959886.

-- 
Best Regards,
Regis.

Mime
View raw message