harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [vote] Declare r946981 as 6.0 milestone 2
Date Wed, 26 May 2010 17:24:42 GMT

In message <201005261641.o4QGf7hx023466@d06av03.portsmouth.uk.ibm.com>,
Mark Hindess writes:
> 
> In message <4BFB875A.6000208@googlemail.com>, Oliver Deakin writes:
> >
> > On 25/05/2010 09:13, Tim Ellison wrote:
> > > I tested on Windows XP, MS VS 2003, Ant 1.7.0
> > >
> > > Same results as 5.0 branch I reported yesterday, with additional
> > > failures in JDWP tests:
> > >
> > > ClassPrepareTest#testClassPrepareEventWithSourceDebugExtension001
> > > ClassPrepareTest#testClassPrepareEventWithSourceDebugExtension002
> > > ClassPrepareTest#testClassPrepareEventWithSourceDebugExtension003
> > >
> > > All failed in JDWPTestCase.java line 752 with:
> > > Invalid event kind, expected:<8(CLASS_PREPARE)>  but was:<99(VM_DEATH)>
> > 
> > I see a similar set of failures in my first test run onWindows x86. I'm 
> > rerunning the 6.0 tests at the moment to check if my failures are 
> > consistent. Apart from those 3 I did not see any other unusual failures.
> 
> I see these failures if I run them together but I can't reproduce them
> if I try to debug the test with:
> 
>   target/hdk/jdk/jre/bin/java \
>      -cp target/hdk/build/test/jpda/jpda_tests.jar:target/hdk/build/test/juni
> t.jar org.junit.runner.JUnitCore \
>     org.apache.harmony.jpda.tests.jdwp.MultiSession.ClassPrepareTest
> 
> We need to take a better look at these jdwp issues after the releases.

Actually it says it is passing but actually it is reporting:

STDERR> java.lang.ClassNotFoundException: org.apache.harmony.jpda.tests.jdwp.Events.SourceDebugExtensionMockClass
STDERR>         at java.lang.Class.forName(Class.java:129)
STDERR>         at org.apache.harmony.jpda.tests.jdwp.Events.ClassPrepareDebuggee.run(ClassPrepareDebuggee.java:55)
STDERR>         at org.apache.harmony.jpda.tests.share.Debuggee.runDebuggee(Debuggee.java:84)
STDERR>         at org.apache.harmony.jpda.tests.jdwp.Events.ClassPrepareDebuggee.main(ClassPrepareDebuggee.java:38)

because the jdktools/modules/jpda/src/test/resources is missing from the 
jdpa_tests.jar.

Adding this path to the -cp makes it pass.  I'll fix this after release.

This might cause the VM_DEATH when run as a batch I suppose ... but
since we weren't previously including any of the jpda tests in the
releases it is not exactly a regression.

Regards,
 Mark.




Mime
View raw message