harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin Fitzpatrick <co...@solas.net>
Subject Build Test System
Date Mon, 26 Apr 2010 15:48:37 GMT
Hi,

First off thanks for the great work on Harmony, it's been a pleasure to work with so far.

I've been trying to get the build-test system up and running for the last few days and I've
run into many problems. I'm not sure if I'm making some incredibly stupid mistake or if there's
something else I need to do.

I'm testing against the latest stable build of harmony, I have all the prerequisites  installed
(JDK 1.5., Ant, SVN, GCC)

I want to use a version of harmony built by a different build process, in a different directory.

I do a SVN checkout:
	svn co http://svn.apache.org/repos/asf/harmony/enhanced/buildtest/trunk/infra

I run
	ant -Dtest.suites="classlib,drlvm,scimark" install

On first build I noticed that lot of dependancies have moved (mostly in SVN), which I've updated.

I update the necessary property files to use the previously build jvm/jre.  It's possible
that I've missed something at this step.

I run 
	ant setup
 without problems

I run
	ant run

This is where I get lots of problems:
	Many ant files appear to have dependancies on other ant files that don't exist or are in
another location.
	Many ant files look for properties in files that don't exist or are in another location.
	Some parts of the run process call ant targets that don't exist.

Without getting into the details of each individual error, my questions are:

	Are these known problems with the build-test system?
	Am I using the build-test system correctly?  Correct version from SVN?

Again, apologies if I've gone down the wrong path.

Colin.



Mime
View raw message