harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin Fitzpatrick <co...@solas.net>
Subject Re: Build Test System
Date Tue, 27 Apr 2010 08:30:12 GMT
Hi Mark,

Thanks for the quick reply.

I'm making some experimental changes to Harmony, especially around the JIT (they may never
be suitable for a real world environment), and I want to do as much automated testing as possible.

I'm planning on using Hudson as well, and I presumed that the build and test system was used
for your hudson tests?	 http://hudson.zones.apache.org/hudson/view/Harmony/job/Harmony-1.5-head-linux-x86_64-full-tests/


If you can point me in the right direction for details on what you use for your hudson jobs,
that would probably make more sense, if not, I can continue working on the build and test
system, and push the changes when I'm finished.

Thanks again.

Colin.


On 27 Apr 2010, at 09:05, Mark Hindess wrote:

> 
> In message <9CB6A426-945E-4EE3-A20F-6F1680BE8EF9@solas.net>, Colin
> Fitzpatrick writes:
>> 
>> Hi,
>> 
>> First off thanks for the great work on Harmony, it's been a pleasure
>> to work with so far.
>> 
>> I've been trying to get the build-test system up and running for the
>> last few days and I've run into many problems. I'm not sure if I'm
>> making some incredibly stupid mistake or if there's something else I
>> need to do.
>> 
>> I'm testing against the latest stable build of harmony, I have all the
>> prerequisites installed (JDK 1.5., Ant, SVN, GCC)
>> 
>> I want to use a version of harmony built by a different build process,
>> in a different directory.
>> 
>> I do a SVN checkout:
>> 	svn co http://svn.apache.org/repos/asf/harmony/enhanced/buildtest/trunk/infra
>> 
>> I run
>> 	ant -Dtest.suites="classlib,drlvm,scimark" install
>> 
>> On first build I noticed that lot of dependancies have moved (mostly
>> in SVN), which I've updated.
>> 
>> I update the necessary property files to use the previously build
>> jvm/jre.  It's possible that I've missed something at this step.
>> 
>> I run
>> 	ant setup
>> without problems
>> 
>> I run
>> 	ant run
>> 
>> This is where I get lots of problems:
>> 	Many ant files appear to have dependancies on other ant files
>> that don't exist or are in another location.
>> 	Many ant files look for properties in files that don't exist or
>> are in another location.
>> 	Some parts of the run process call ant targets that don't exist.
>> 
>> Without getting into the details of each individual error, my questions
>> are:
>> 
>> 	Are these known problems with the build-test system?
>> 	Am I using the build-test system correctly?  Correct version
>> from SVN?
>> 
>> Again, apologies if I've gone down the wrong path.
> 
> I don't think anyone is actively running the buildtest infrastructure at
> the moment so I'm not surprised you are having problems.  (I tried it to
> see if I could reproduce the issues you described but I don't even get
> that far I get the appended errors.)
> 
> The intention is just to use Hudson jobs to expand our testing now that
> Apache provide this service.
> 
> Perhaps if you tell us your goal we can help?  If you just want to do a
> build, you can just do:
> 
>  svn co https://svn.apache.org/repos/asf/harmony/enhanced/java/trunk harmony
>  cd harmony
>  ant fetch-depends build
> 
> and to run scimark:
> 
>  wget http://math.nist.gov/scimark2/scimark2lib.jar
>  target/hdk/jdk/jre/bin/java -cp scimark2lib.jar jnt.scimark2.commandline
> 
> HTH,
> Mark.
> 
> ...
> 
> -download-next:
> 
> -init:
>     [echo] Fetching '${libname}' external dependency for 'scripts' subcomponent.
>     [echo] ===> Library Info: ${libname}
>     [echo]          Basename: ${lib.url}
>     [echo]          Location: /home/hindessm/hy/buildtest/infra/build/libs/${lib.url}
> 
> -fetch-if-necessary:
> 
> -download:
>     [echo] ==> Do Download from ${lib.url} 
> 
> BUILD FAILED
> /home/hindessm/hy/buildtest/infra/build.xml:161: The following error occurred while executing
this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:59: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:112: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:100: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:112: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:100: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:112: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:100: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:112: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:100: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:112: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:92: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:205: The following error occurred
while executing this line:
> /home/hindessm/hy/buildtest/infra/scripts/download.xml:282: java.net.MalformedURLException:
no protocol: ${lib.url}
> 
> 
> 


Mime
View raw message