harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From enh <...@google.com>
Subject Re: [classlib][fdlib] Upgrade fdlibm5.2 to 5.3
Date Wed, 03 Mar 2010 16:23:29 GMT
On Fri, Mar 5, 2010 at 00:56, Regis <xu.regis@gmail.com> wrote:

> On 2010-03-03 16:34, Deven You wrote:
>
>> See https://issues.apache.org/jira/browse/HARMONY-6460, since java spec
>> require fdlibm5.3, I think we should upgrade it from at present 5.2 to
>> 5.3.
>> What about your opinions? Thanks a lot!
>>
>>
> Great founding! It seems fdlibm5.3 is released earlier than Harmony project
> starting (fdlibm5.3 revised October 2002, when Harmony project is not
> started yet), I don't know why we didn't pick the latest version, but used
> the older one. Is there any concern here?


i checked the version of fdlibm in Android's underlying OS, and that's 5.3.
the only fdlibm problem i've seen is that some versions of GCC for ARM at
some optimization levels -- and only when generating code for NEON --
incorrectly optimize tanh. an existing harmony test spots this [a 0.0 versus
-0.0 mixup], and i've no reason to believe that GCC wouldn't mangle the 5.2
code in the same way.

(the GCC bug is fixed.)

so as far as we know, 5.3 should be fine.

 --elliott


> If not, I think we should upgrade it after M13 released.
>
> --
> Best Regards,
> Regis.
>



-- 
Elliott Hughes - http://who/enh - http://jessies.org/~enh/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message