harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [testing]Some benchmark doesnot run properly in Harmony JVM
Date Sun, 21 Mar 2010 14:18:05 GMT

In message <201003211957200390550@mail.ustc.edu.cn>, "Li QuanLong" writes:
> Hi all:
>     I am a reascher on Java memory management with the platform of
> Apache Harmony.I have got Harmony with version 608801(GCv5) and
> 794696, I did not take any changes on them. I found that it does not
> work properly when i run some benchmark in Harmony JVM.
> Take benchmark suite Dacapo for example,it has Register Exception when
> I run eclipse, Nullpoint Exception when I run fop and h2. the version
> of Dacapo is 20091224,the newest release of Dacapo benchmark suite.
> Did you have these problem when you run some benchmark with Harmony
> and how you solve it? Your reply will be appreciated!
>     Thanks!
> 2010-03-21 
> Li QuanLong

Those versions are very old from January 2008 and July 2009
respectively.  Have you tried with anything current, such as milestone
13 or the latest trunk?

The eclipse benchmark was broken on M12(a) but I fixed it in M13.  The
h2 benchmark works fine for me on all the milestone releases I've tried
(though I didn't test M5).

"fop" doesn't work for me.  I've not looked at why.  It may be a
harmony bug (perhaps due to missing function in Harmony awt which is
not complete) or it may be that the benchmark depends on Sun non-API
classes.  There is a proposed GSoC project[0] to look at the remaining
dacapo failures.


[0] https://issues.apache.org/jira/browse/HARMONY-6445

View raw message