harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [classlib][fdlib] Upgrade fdlibm5.2 to 5.3
Date Wed, 03 Mar 2010 09:31:16 GMT
+1

Thanks Deven.

We should move to a process that downloads the upstream zip using the
standard {check,fetch}-depends mechanism to make it easier to update in
future.  Ideally the dependency should be pushed down to the luni module
where it really belongs.

Regards,
-Mark.

In message <4B90C728.5020509@gmail.com>, Regis writes:
>
> On 2010-03-03 16:34, Deven You wrote:
> > See https://issues.apache.org/jira/browse/HARMONY-6460, since java spec
> > require fdlibm5.3, I think we should upgrade it from at present 5.2 to 5.3.
> > What about your opinions? Thanks a lot!
> >
> 
> Great founding! It seems fdlibm5.3 is released earlier than Harmony project 
> starting (fdlibm5.3 revised October 2002, when Harmony project is not started
>  
> yet), I don't know why we didn't pick the latest version, but used the older 
> one. Is there any concern here? If not, I think we should upgrade it after M1
> 3 
> released.
> 
> -- 
> Best Regards,
> Regis.
> 



Mime
View raw message