harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Wu <wuyue...@gmail.com>
Subject Re: 6.0 Milestone testing -windowsXP-32
Date Tue, 05 Jan 2010 06:51:55 GMT
Hi Ray
I run it separately and got only one error left

	test_joinGroupLjava_net_SocketAddressLjava_net_NetworkInterface	Error	The
address is not available

java.net.SocketException: The address is not available
at org.apache.harmony.luni.platform.OSNetworkSystem.setSocketOption(OSNetworkSystem.java)
at org.apache.harmony.luni.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:302)
at org.apache.harmony.luni.net.PlainDatagramSocketImpl.joinGroup(PlainDatagramSocketImpl.java:209)
at java.net.MulticastSocket.joinGroup(MulticastSocket.java:257)
at org.apache.harmony.luni.tests.java.net.MulticastSocketTest$MulticastServer.(MulticastSocketTest.java:129)
at org.apache.harmony.luni.tests.java.net.MulticastSocketTest.test_joinGroupLjava_net_SocketAddressLjava_net_NetworkInterface(MulticastSocketTest.java:521)
at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)


On Mon, Jan 4, 2010 at 11:32 AM, Ray Chen <clraychen@gmail.com> wrote:
> Hi Tony,
> MulticastSocketTest all passed on my machine (I ran it standalone).
> Maybe you can run it standalone on your machine to see if it can pass.
>
> On Fri, Dec 25, 2009 at 2:56 PM, Tony Wu <wuyuehao@gmail.com> wrote:
>> got latest testing result here
>> http://people.apache.org/~tonywu/r893424-60m1-winxp32-vs2008/
>>
>> On Wed, Dec 23, 2009 at 8:07 AM, Nathan Beyer <nbeyer@gmail.com> wrote:
>>> Here's my results for windows x86 testing with vs2003 build of java6
>>> branch on Windows Vista.
>>>
>>> http://people.apache.org/~ndbeyer/harmony/windows-x86-java6/html/
>>>
>>> I think two of the errors are due to running in a virtual machine and
>>> the network config I have.
>>>
>>> -Nathan
>>>
>>> On Tue, Dec 22, 2009 at 9:52 AM, Tony Wu <wuyuehao@gmail.com> wrote:
>>>> pls check the testing result w/o awt and swing here
>>>> http://people.apache.org/~tonywu/r893171-60m1-winxp32-vs2008/
>>>>
>>>> seems I got more errors than yours?
>>>>
>>>> On Tue, Dec 22, 2009 at 5:14 PM, Tony Wu <wuyuehao@gmail.com> wrote:
>>>>> the federated build works for me. but still don't know what's the
>>>>> reason for my non-federated build. Anyway I can keep moving and post
>>>>> my testing result on win32 with VS 2008
>>>>>
>>>>> On Mon, Dec 21, 2009 at 10:46 PM, Tony Wu <wuyuehao@gmail.com>
wrote:
>>>>>> On Mon, Dec 21, 2009 at 9:55 PM, Mark Hindess
>>>>>> <mark.hindess@googlemail.com> wrote:
>>>>>>>
>>>>>>> In message <211709bc0912210522i5a2fd37cqd21d0b9099c1b182@mail.gmail.com>,
>>>>>>> Tony Wu writes:
>>>>>>>>
>>>>>>>> change the junit fork to "no" and it passes.  anyone came
across this
>>>>>>>> issue before?
>>>>>>>
>>>>>>> I'm a little confused as to how you are running the tests.  A
simple:
>>>>>>>
>>>>>>>  ant test
>>>>>>>
>>>>>>> at the top level of the federated build should suffice.
>>>>>>>
>>>>>>> However, the paths in your output look like:
>>>>>>>
>>>>>>>   deploy/jdk/jre/bin/java
>>>>>>>
>>>>>>> where as I would expect them to be pointing at the combined hdk
for
>>>>>>> the federated build which has a path like:
>>>>>>>
>>>>>>>   target/hdk/jdk/jre/bin/java
>>>>>>>
>>>>>>> The deploy directories in component directories (working_*/deploy)
are
>>>>>>> all incomplete so it only make sense to run the tests against
the merged
>>>>>>> tree in target/hdk/...
>>>>>>>
>>>>>>> If you wish to run the tests from working_classlib then you need
to set
>>>>>>> the test.jre.home property to point back up to the absolute path
of the
>>>>>>> target/hdk/jdk/jre directory.
>>>>>>
>>>>>> Hi, Mark
>>>>>>
>>>>>> I just built it in a separate workingcopy of classlib/branches/java6
>>>>>> and then copied a binary of DRLVM into bin/default. I tried to set
>>>>>> test.jre.home to jdk/jre/bin, and it didn't work. I'm not sure the
>>>>>> problem I'm experiencing is caused by the VS2008 or non-federated
>>>>>> build.
>>>>>>
>>>>>> Will try on federated tomorrow. if it still doesn't work, I have
to
>>>>>> install a VS 2003 :-(
>>>>>>
>>>>>>>
>>>>>>> HTH,
>>>>>>>  Mark.
>>>>>>>
>>>>>>>> On Mon, Dec 21, 2009 at 4:57 PM, Tony Wu <wuyuehao@gmail.com>
wrote:
>>>>>>>> > with vs2008 + winxp x86 32bit, I resolved the compier
error but got
>>>>>>>> > following error when run the tests.
>>>>>>>> >
>>>>>>>> > -get-test-vm-output:
>>>>>>>> >  [exec] Execute failed: java.io.IOException: CreateProcess:
D:\workingcopy\b
>>>>>>>> > ranch6\deploy\jdk\jre\bin\java -version error=193
>>>>>>>> >
>>>>>>>> > test-jre-vm-info:
>>>>>>>> >  [echo] java -version
>>>>>>>> >  [echo] ${test.vm.info.tmp}
>>>>>>>> >  [echo] hy.test.vm.name = drl
>>>>>>>> >
>>>>>>>> > test-module:
>>>>>>>> >  [echo] Running luni Unit Test from luni_tests_api.jar
>>>>>>>> >  [echo] Tested jre: D:\workingcopy\branch6\deploy\jdk\jre/bin/java
>>>>>>>> >  [mkdir] Created dir: D:\workingcopy\branch6\build\test_report
>>>>>>>> >  [junit] Running org.apache.harmony.luni.tests.util.UtilTest
>>>>>>>> >  [junit] Tests run: 1, Failures: 0, Errors: 1, Time
elapsed: 0 sec
>>>>>>>> >
>>>>>>>> > BUILD FAILED
>>>>>>>> > D:\workingcopy\branch6\build.xml:181: The following
error occurred while
>>>>>>>> > executing this line:
>>>>>>>> > D:\workingcopy\branch6\make\build-test.xml:54: The following
error occurred
>>>>>>>> > while executing this line:
>>>>>>>> > D:\workingcopy\branch6\make\properties.xml:529: The
following error occurred
>>>>>>>> > while executing this line:
>>>>>>>> > D:\workingcopy\branch6\make\properties.xml:541: The
following error occurred
>>>>>>>> > while executing this line:
>>>>>>>> > D:\workingcopy\branch6\modules\luni\build.xml:334: The
following error
>>>>>>>> > occurred while executing this line:
>>>>>>>> > D:\workingcopy\branch6\deploy\build\test\luni\build.xml:36:
The following
>>>>>>>> > error occurred while executing this line:
>>>>>>>> > D:\workingcopy\branch6\make\properties.xml:732: Process
fork failed.
>>>>>>>> >
>>>>>>>> > seems the java -version does not work, but I it works
when I try it
>>>>>>>> > manually,
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Tony Wu
>>>>>> China Software Development Lab, IBM
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Tony Wu
>>>>> China Software Development Lab, IBM
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Tony Wu
>>>> China Software Development Lab, IBM
>>>>
>>>
>>
>>
>>
>> --
>> Tony Wu
>> China Software Development Lab, IBM
>>
>
>
>
> --
> Regards,
>
> Ray Chen
>



-- 
Tony Wu
China Software Development Lab, IBM

Mime
View raw message