harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexei Fedotov <alexei.fedo...@gmail.com>
Subject Status of UI tests in Hudson run Was: [vote] Declare r885602 as Milestone 5.0 M12
Date Sat, 05 Dec 2009 10:57:18 GMT
Mark,
I have exammined few exception stack traces in Tim's run. They refer
to the following exceptions:

    java.lang.NoClassDefFoundError: javax/swing/JButton
    java.lang.NoClassDefFoundError: javax/swing/UIManager

I believe these particular tests likely fail due to the absence of swing.jar.



On Sat, Dec 5, 2009 at 1:52 AM, Mark Hindess
<mark.hindess@googlemail.com> wrote:
>
> In message <4B183385.3050509@gmail.com>, Tim Ellison writes:
> >
> > On 03/Dec/2009 19:47, Mark Hindess wrote:
> > > In message <4B17FF11.1040906@gmail.com>, Tim Ellison writes:
> > >> On 03/Dec/2009 17:37, Alexei Fedotov wrote:
> > >>> I have noticed [1] that in addition to awt and swing tests the tests
> > >>> from the followng packages are broken:
> > >>> java.beans
> > >>> java.util.jar
> > >>>
> > >>> Do we care?
> > >>>
> > >>> [1] http://www.telebridge.ru/harmony/
> > >> Wow, there are thousands of failures there!!  Yes, we care!
> > >>
> > >> What is happening with your machine?  I see it is
> > >> svn = rr885602, (Dec 3 2009), Linux/ia32/gcc 4.3.2
> > >>
> > >> and I guess it is running headless?  I think the problems stem from
> > >> that, since I see in your output [1]:
> > >> java.lang.NullPointerException
> > >>    at java.awt.Toolkit.getNativeEventQueue(Toolkit.java:1172)
> > >>    at java.awt.EventDispatchThread.run(EventDispatchThread.java:46)
> > >> java.lang.InternalError: Cannot open display ''
> > >>
> > >> [snip]
> > >>
> > >> On such a system the best you can hope for is to run all but awt, swing,
> > >> and beans, like we do through Hudson
> > >>
> > >> xvfb-run -a -e xvfb-run.log ant -Dexclude.module=awt,beans,swing test
> > >
> > > If you are using xvfb then there should be no reason not to run the
> > > awt/swing tests.
> >
> >
> > ...and yet
> >
> > http://hudson.zones.apache.org/hudson/view/Harmony/job/Harmony-1.5-head-linux
> > -x86_64-full-tests/29/
> >
> > I've excluded them again.
>
> Looks like the xserver is failing to start.  Try:
>
>  sudo apt-get install x11-xkb-utils
>
> -Mark.
>
>



--
With best regards / с наилучшими пожеланиями,
Alexei Fedotov / Алексей Федотов,
http://www.telecom-express.ru/
http://harmony.apache.org/
http://www.expressaas.com/
http://openmeetings.googlecode.com/

Mime
View raw message