harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Beyer <ndbe...@apache.org>
Subject Re: java 6 branch -version reports 1.5.0?
Date Sun, 13 Dec 2009 02:11:45 GMT
On Sat, Dec 12, 2009 at 3:05 AM, Mark Hindess
<mark.hindess@googlemail.com> wrote:
>
> In message <3b3f27c60912101902u5c49e5c2o3b7fb9f300833b84@mail.gmail.com>,
> Nathan Beyer writes:
>>
>> I've been doing testing on the java 6 branch and was looking over the
>> results and noticed that the version info reports 1.5.0 ... I thought
>> we did something about that? I think I have the build setup correctly,
>> though maybe not.
>
> There are two ways to build the java6 branch.  The "old" way is:
>
>  svn co https://svn.apache.org/repos/asf/harmony/enhanced/trunk hy6
>  cd hy6
>  ant -Djava6=true populate-src
>  ant -Djava6=true
>
> and the new way:
>
>  svn co https://svn.apache.org/repos/asf/harmony/enhanced/branches/java6 hy6
>  cd hy6
>  ant populate-src
>  ant
>
> I suspect that you are using the "old" way and not supplying the
> -Djava6=true parameter to the build.  (Previously the -Djava6=true
> parameter only affected the populate-src target but now it affects the
> build too.)
>
> I think we should deprecate/remove the "old" way to avoid this confusion.

Oh ... let me try that. Yes, we should remove any "old" ways.

>
> -Mark.
>
>
>
>

Mime
View raw message