harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xiao-Feng Li <xiaofeng...@gmail.com>
Subject Re: Build error of Harmony
Date Wed, 09 Sep 2009 13:30:33 GMT
Can it be a conflict in header file name "TypeDefinition.h" or in the
type name "fint"? I saw this kind of failures sometimes.

Thanks,
xiaofeng

On Wed, Sep 9, 2009 at 9:12 PM, 王智超<solospider@gmail.com> wrote:
> Hi Charles,
>
> Thanks for your reply. I have read the link, but I think it is not the same
> issue with me.
> I still feel confused about this error, actually I don't think there is any
> error in the code.
>
> Have you build harmony on XP machine? what compiler did you use?
> I think maybe it is caused by the compiler (VC 2008)
>
> Thanks,
> Norman
>
> 2009/9/9 Charles Lee <littlee1032@gmail.com>
>
>> Hi Norman,
>>
>> Pleae check HARMONY-5948[1]. Hope this will help you.
>>
>> [1]: https://issues.apache.org/jira/browse/HARMONY-5948
>>
>> On Wed, Sep 9, 2009 at 2:55 PM, 王智超 <solospider@gmail.com> wrote:
>>
>> > Hi
>> >
>> > I am a newbie of Harmony community, now I am trying to build harmony.
>> > I have followed the instruction of "Getting Started For Contributors",
>> when
>> > I execute the "ant -Dauto.fetch=true all" command, it showed the
>> following
>> > error message:
>> >
>> >     [exec] EncodedValue.cpp
>> >     [exec]     cl -c -DCRTAPI1=_cdecl -DCRTAPI2=_cdecl -nologo -GS
>> > -FIsehmap.h -D_X86_=1  -DWIN32 -D_WIN32 -W3 -D_WIN95
>> > -D_WIN32_WINDOWS=0x0400
>> > /D_WIN32_DCOM -D_WIN32_IE=0x0500 -DWINVER=0x0400 -Zi -Od -WX -GF -Gs -MD
>> > -Zm400   -D_CRT_SECURE_NO_DEPRECATE  -D_CRT_SECURE_NO_WARNINGS
>> > -D_SCL_SECURE_NO_D
>> > EPRECATE  -D_DLL -D_MT -D_WINSOCKAPI_
>> > /IE:\Harmony\trunk\working_classlib\deploy\include
>> > /IE:\Harmony\trunk\working_classlib\deploy\jdk\include /I.
>> > /I..\shared\include /I..\shared\  /EHsc -Fo..\shared\Environment.obj
>> > ..\shared\Environment.cpp
>> >     [exec] Environment.cpp
>> >     [exec]
>> >
>> >
>> e:\harmony\trunk\working_classlib\modules\awt\src\main\native\fontlib\shared\TypeDefinition.h(21)
>> > : error C2144: syntax error : 'int' should be preceded by ';'
>> >     [exec]
>> >
>> >
>> e:\harmony\trunk\working_classlib\modules\awt\src\main\native\fontlib\shared\TypeDefinition.h(21)
>> > : error C4430: missing type specifier - int assumed. Note: C++ does not
>> > support default-int
>> >     [exec] NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual
>> > Studio 9.0\VC\BIN\cl.EXE"' : return code '0x2'
>> >     [exec] Stop.
>> >
>> > My environment is: Windows XP/x86, VC2008 express, JDK 1.5.0_19 (Sun
>> > Microsystems Inc.)
>> >
>> > I checked the TypeDefinition.h, there is only some typedef code, there is
>> > not any syntax error in my opinion.
>> > Could anyone pleased to tell me why this error happen and how to fix it?
>> >
>> > Thanks,
>> > Norman
>> >
>>
>>
>>
>> --
>> Yours sincerely,
>> Charles Lee
>>
>



-- 
http://people.apache.org/~xli

Mime
View raw message