harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: dev@harmony.apache.org
Date Wed, 19 Aug 2009 12:05:43 GMT

In message <0016e6d99cc1d9f38a04717d10e7@google.com>,
florian.harmuth@googlemail.com writes:
>
> Hello all,
> i try to use a self compiled version of the harmonyvm. The following output  
> occurs:
> 
> sh-4.0# java -version
> Apache Harmony Launcher : (c) Copyright 1991, 2009 The Apache Software  
> Foundation or its licensors, as applicable.
> Failed to open JVM DLL: /opt/harmony-jre-782693/bin/default/harmonyvm  
> (/opt/harmony-jre-782693/bin/default/libharmonyvm.so: undefined symbol:  
> __sync_fetch_and_add_4)
> 
> I have searched trough the web and i have only found i386<->i486 issues.  
> Anyone know what's my fault?
> 
> Best regards,
> 
> flo

This looks like a glibc compatibility problem.  It looks like you are
using a binary download of the M10 jre and a modified libharmonyvm.so?

I assume the download with the original libharmonyvm.so works?

I'd try a federated build compiled from the source in svn or the M10
source.  Confirm that this works. Then try copying your self-compiled
version of libharmonyvm.so over that.

Regards,
 Mark.



Mime
View raw message