harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexey Varlamov <alexey.v.varla...@gmail.com>
Subject Re: [classlib] minimum ant version
Date Thu, 16 Jul 2009 07:11:15 GMT
+1

2009/7/16, Nathan Beyer <ndbeyer@apache.org>:
> I'd be fine with going all the way to 1.7.1, as it's distributed with
> Ubuntu and other Linux distros, but I'm fine with 1.7.
>
> On Wed, Jul 15, 2009 at 5:07 AM, Mark
> Hindess<mark.hindess@googlemail.com> wrote:
> >
> > I've just noticed that our web site says Harmony developers need:
> >
> >  Apache Ant version 1.6.5 or higher
> >
> > but that the changes I checked in last night (to make accessibility and
> > security run the tests by running them in the hdk rather than "in" classlib)
> > use <junit><batchtest><zipfileset>s which were new in 1.7.0.
> >
> > I'm happy to back out the change temporarily.  However:
> >
> > 1) I think that requiring 1.7.0 which was released in December 2006 isn't
> >   unreasonable.
> >
> > 2) I think running tests in the hdk is desirable and using jars (and thus
> >   zipfilesets) is the natural way to do this.
> >
> > 3) I think running tests in two ways (i.e. in classlib and in the hdk) is
> >   undesirable since most developers will only use one of the ways (in
> >   classlib) and thus not notice when the other way breaks.
> >
> > 4) I think having one way to run the tests will make the ant infrastructure
> >   easier to maintain.
> >
> > so I think requiring 1.7.0 is probably the right thing to do at some point.
> >
> > Why not now?  What do you think?
> >
> > Regards,
> >  Mark.
> >
> >
> >
>

Mime
View raw message