harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Beyer <nbe...@gmail.com>
Subject Re: Build failed in Hudson: Harmony-1.5-head-linux-x86_64 #116
Date Tue, 28 Apr 2009 23:17:06 GMT
On Tue, Apr 28, 2009 at 3:19 PM, Tim Ellison <t.p.ellison@gmail.com> wrote:
> I realize that I'm having this conversation with myself, but anyway...
>
> Tim Ellison wrote:
>> Tim Ellison wrote:
>>> FYI I deleted the Hudson workspace, and now it shows the same errors as
>>> Andrew trying to download the dependencies.
>>>
>>> Normal service will be resumed shortly...once we have figure out where
>>> things moved.
>>
>> The dependencies download now ok, but the architecture detection has
>> gone squiffy:
>
> I was running the build on an x86_64 bit machine, but using a 32-bit
> JRE, so the os.arch was reporting it as a x386, which in turn caused Ant
> to report the OS as x86, which made our scripts build in 32-bit mode,
> and so on.
>
> Building with a 64-bit JRE seems to solve the problem.
>

I'm running Ubuntu 9.0.4 and I'm getting this oddness.

     [echo]                    Apache Harmony Federated Build
     [echo]             ==========================================
     [echo]             svn rev          :  769579
     [echo]             operating system :  linux
     [echo]             architecture     :  x86_64-64
     [echo]             ant os name/arch :  Linux/amd64
     [echo]             hosting Java     :  1.6.0_13 (Sun Microsystems Inc.)
     [echo]             build mode       :  release
     [echo]             output location  :  target
     [echo]             SVN root         :  https://svn.apache.org/repos/asf

$> uname -a
Linux massimo 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC
2009 x86_64 GNU/Linux

> Hudson now back to normal.
>
> Regards,
> Tim
>
>

Mime
View raw message