harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Beyer <nbe...@gmail.com>
Subject Re: Remaining M9 issues
Date Thu, 26 Mar 2009 03:09:30 GMT
On Wed, Mar 25, 2009 at 12:28 PM, Nathan Beyer <nbeyer@gmail.com> wrote:
>
>
> On Mar 25, 2009, at 5:54 AM, Tim Ellison <t.p.ellison@gmail.com> wrote:
>
>> Tim Ellison wrote:
>>>
>>> 2. hymem.exe crashes on Vista
>>>
>>> ?JIRA?  Regression?
>>
>> Nathan, any details on this crash you are seeing?
>>
>> Looking at the tests, they are testing the fundamental hymem_ functions
>> in the portlibrary, and not particularly extensively.  If these are
>> failing then the class library natives would be completely broken.
>>
>> You say there is a crash dialog.  Can you put it into a JIRA please, or
>> a stack trace, or some of the printf's, ...
>>

Maybe I've just been doing something wrong all along. One way it
works, another it crashes. Here's what I'm doing.

1. I have the basic federated build setup.
2. 'ant rebuild' from top-folder, 'trunk'
3. 'cd working_classlib\modules\portlib'
4. 'ant test' - all of the native test pass just fine
5. 'cd ..\..\..\' - go back up to top-folder
6. 'robocopy /mir target\hdk working_classlib\deploy' - copy the
federated build to classlib's deploy folder
7. 'cd working_classlib'
8. 'ant test' - after a bit, portlib tests are run and hymem.exe test
blows up in the 'hymem_free_memory' method

Is this the wrong way to test the class library? Why would this funk
up the portlib tests?

>
> I will put what I can in an issue. I was hoping another vista user would pop
> up and validate or invalidate.
>
>
>> Thanks,
>> Tim
>

Mime
View raw message