harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [M9] Testing - outstanding issues
Date Tue, 24 Mar 2009 15:52:06 GMT

In message <49C8EA59.40801@gmail.com>, Tim Ellison writes:
>
> chunrong lai wrote:
> > I also once investigated the issue times ago
> > http://mail-archives.apache.org/mod_mbox/harmony-dev/200809.mbox/%3cf9761b910809160814s7fd8e257gd99b4a15d97008c0@mail.gmail.com%3e
> > and identified the guity commit which breaks SSLSocketImplTest as
> > r691267.
> > 
> > What r691267 did is "Remove the hy.no.sig option and make it the default."
> > so it is basically a classlib patch. It seems that its modifications to vm
> > makefiles finally make the test crashed.
> 
> I suggest you raise a JIRA issue for this (if one does not exist
> already) and bring it to the attention of the committer.

Well, I am the committer but I'm not going to be much help since I can't
reproduce the problem.  I've tested on linux/x86 and linux/x86_64 with:

  ant
  cd working_classlib
  ant -Dtest.jre.home=../target/hdk/jdk/jre \
      -Dtest.case=org.apache.harmony.xnet.provider.jsse.SSLSocketImplTest \
      -Dbuild.module=x-net test

and it works for me.  I also tried using:

  -Dtest.jre.home=../working_vm/build/linux_x86_gcc_release/deploy/jdk/jre

as I notice this is what Chunrong (incorrectly?) uses and thinking it might
be a federation build/layout issue but that works too.

I tried downloading the snapshot from:

  http://people.apache.org/builds/harmony/snapshots/r751364/apache-harmony-jre-r751364-linux-x86-32-snapshot.tar.gz

but that works for me too.

Sadly, the integrity test crash output gives no useful information for
diagnosing the problem.

Chunrong, can you give me more information about the test environment where
you see this problem?  What distribution?  What libc version?  What kernel 
version?

Regards,
-Mark.



Mime
View raw message