harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chunrong lai <chunrong...@gmail.com>
Subject Re: [eut] Something about EUT relEng
Date Thu, 26 Feb 2009 06:07:35 GMT
 I tried to investigated the issue but have not succeed.
 (1) Since it is an intermittent error in my machines, I guess that it is a
threading-related issue.  I then tried previous of drlvm and could still
observe the intermittent failure in M5 (r629320). I also checked RI and VME
and have not seen such problem.
 (2) Observed same stacktrace, I see there is no problem to parse such files
in a single-threaded environment, same as what Charles observed. Looking
more in EUT35 source, I see that EUT open the file with BufferedInputStream
and then pass the stream to SAXParser. The stacktrace itself likely shows
that we can read nothing from the BufferedInputStream. I guessed that  there
might be some problems in drlvm when cooperated with the threaded
BufferedInputStream but have not verified it.

On Thu, Feb 26, 2009 at 1:11 PM, Charles Lee <littlee1032@gmail.com> wrote:

> Hi guys,
> I'm running EUT releng test on the linux machine. The test is always
> failed. Here is something I found, and need some help:
> 1. I have encountered a " [Fatal Error] :1:20: The version is required in
> the XML declaration." when running java-test target just like what Lai
> ChunRong mentioned in HARMONY-6062<http://issues.apache.org/jira/browse/HARMONY-6062>,
> but without any luck to pass the test occasionally.
> 2. With the -consolelog, I found the log file (attached), and says
> "java.io.IOException: The version is required in the XML declaration." The
> exception is thrown by the eclipse ProfileParser, which is parsing a profile
> (attached). The profile is complete. The stack trace contains no information
> about harmony. With these information, I guess there maybe something wrong
> when the SAXParser parse a file. So I have run a test to check SAXParser
> only to find there is no problem to parse the same log.
> 3. I have tested the relEng with RI. RI passed the configuration phase, but
> will setup a eclipse workbench and never close it. Harmony with current ibm
> vm behaves the same.
> 4. I have tested the relEng on windows. The relEng test passed but behavior
> different from what it does on linux. No workbench is setup. I have checked
> the test.xml about the relEng test, find this line in the setupcompare:
>     "only run compare test on Linux machine since it is the fastest
> machine. Also, the compare tool only parses feature.xmls so it only needs to
> be run on one machine"
>     On linux, target setupcompare will be run. It will download a eclipse
> with older version and change some configuration to compare with the newest
> one.    I guess here is reason what makes difference.
>
> Any idea?
>
> --
> Yours sincerely,
> Charles Lee
>
>
>
>
> --
> Yours sincerely,
> Charles Lee
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message