harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chunrong lai" <chunrong...@gmail.com>
Subject Re: testing for the newer EUT
Date Thu, 15 Jan 2009 01:40:10 GMT
I run EUT35 in windows so far. As to EUT33, I run it in both windows and
linux.
Thanks.

On Wed, Jan 14, 2009 at 2:38 PM, Nathan Beyer <ndbeyer@apache.org> wrote:

> Are you doing both Windows and Linux? I'm just doing Windows, Vista to
> specific.
>
> -Nathan
>
> On Mon, Jan 12, 2009 at 5:08 PM, chunrong lai <chunronglai@gmail.com>
> wrote:
> > Thanks. I'd like to have a try.
> > Maybe you can also try the java command line running (after clean
> > extraction) and post the running results?
> >
> > On Tue, Jan 13, 2009 at 12:05 AM, Nathan Beyer <ndbeyer@apache.org>
> wrote:
> >
> >> Maybe the difference is the milestone I'm testing. Have you tried
> >> moving to the next milestone release?
> >>
> >> On Mon, Jan 12, 2009 at 1:26 AM, chunrong lai <chunronglai@gmail.com>
> >> wrote:
> >> > Thanks.
> >> > (1) My default JRE is also Harmony JVM.
> >> >     I tried to set public JRE as SUN JRE and specify Harmony VM with
> >> "-vm"
> >> > in runtests.bat but just get same results as my previous running.
> >> >
> >> > (2) I think that there are not two JVM executables if run it with java
> >> > command lines. So the harness issue does not exist if we can reproduce
> >> the
> >> > error there.
> >> >     Yes. There are two java executables in scripts based running, like
> >> the
> >> > "jvm" and "vm" option for runtests.bat or the java executable in path
> or
> >> in
> >> > eut.run.properties (for test.xml).
> >> >
> >> >      java -jar
> >> > eclipse/plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar -data
> >> > workspace -application org.eclipse.ant.core.antRunner -file test.xml
> >> jdttext
> >> > -Dos=linux -Dws=gtk -Darch=x86 -Dclean=true -propertyfile
> >> eut.run.properties
> >> > -logger org.apache.tools.ant.DefaultLogger
> >> >
> >> >
> >> >
> >> > On Mon, Jan 12, 2009 at 2:55 PM, Nathan Beyer <ndbeyer@apache.org>
> >> wrote:
> >> >
> >> >> It must be the 'jvm' property in that file. When I add that, it uses
> >> >> the Harmony JRE to run the tests. However, the test harness is still
> >> >> run with the public JRE (in my case, Sun's JRE).
> >> >>
> >> >> Would you mind trying to add "-vm path/to/harmony" to runtests and
> >> >> seeing what results to get from a clean start? I'd like to know if
> >> >> you're getting the same failures. The console output doesn't show
> >> >> much, but when you look at the results, no tests were run and the log
> >> >> shows some weird errors in equinox.
> >> >>
> >> >> -Nathan
> >> >>
> >> >> On Mon, Jan 12, 2009 at 12:47 AM, chunrong lai <
> chunronglai@gmail.com>
> >> >> wrote:
> >> >> > I run it with
> >> >> >  runtests -properties eut.run.properties jdtcorebuilder
> >> >> >
> >> >> > or
> >> >> > D:\eclipse-testing>java -jar
> >> >> >
> >> eclipse\plugins\org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
> >> >> > -application org.eclipse.test.coretestapplication -data workspace
> -dev
> >> >> bin
> >> >> >
> >> >>
> >>
> formatter=org.apache.tools.ant.taskdefs.optional.junit.XMLJUnitResultFormatter,d:\eclipse-testing\eclipse\org.eclipse.jdt.core.tests.builder.BuilderTests.xml
> >> >> > -testPluginName org.eclipse.jdt.core.tests.builder -className
> >> >> > org.eclipse.jdt.core.tests.builder.BuilderTests -os win32 -ws
win32
> >> -arch
> >> >> > x86
> >> >> > after manual clean/extraction.
> >> >> >
> >> >> > I also tried "runtests -properties eut.run.properties" and saw
> those
> >> >> > jdtcorebuilder errors are reproducible.
> >> >> > On Mon, Jan 12, 2009 at 12:42 PM, Nathan Beyer <ndbeyer@apache.org
> >
> >> >> wrote:
> >> >> >
> >> >> >> When I don't specificy "-vm", then it uses the 'java' executable
> in
> >> my
> >> >> >> path that Sun's public JRE installed, for all invocations.
All I
> have
> >> >> >> set in my properties file is the "J2SE-1.5" property. What
does
> the
> >> >> >> "jvm" property do?
> >> >> >>
> >> >> >> I presume you're running "runtests -properties eut.run.properties
> >> all".
> >> >> >>
> >> >> >> -Nathan
> >> >> >>
> >> >> >> On Sun, Jan 11, 2009 at 10:19 PM, chunrong lai <
> >> chunronglai@gmail.com>
> >> >> >> wrote:
> >> >> >> > hi, Nathan:
> >> >> >> >     I have not tried 3.5M4 but just tried 3.5M3.
> >> >> >> >     According to the attched "Readme.htm", one only needs
to
> >>  specify
> >> >> the
> >> >> >> > (J2SE) item of eut.run.properties (I attached mine) and
then run
> >> >> >> >
> >> >> >> > runtests -properties <path to properties file>
[-os <operating
> >> >> system>]
> >> >> >> [-ws
> >> >> >> > <windowing system>] [-arch <architecture>]
[-noclean] [-vm <path
> to
> >> >> java
> >> >> >> > executable>][-Dtest.target=performance][targetname1
targetname2
> >> >> >> targetname3
> >> >> >> > etc...]
> >> >> >> >     for that. You can read the "Requirements" session
in it. It
> >> seems
> >> >> >> that
> >> >> >> > the requirements (winzip, ant) are minimum.
> >> >> >> >     Detailed steps of the testing can be found in
> >> >> >> >
> >> >>
> >>
> http://www.eclipse.org/articles/Article-PDE-Automation/automation.html(around
> >> >> >> > Fig 13).
> >> >> >> > On Mon, Jan 12, 2009 at 11:48 AM, Nathan Beyer <
> ndbeyer@apache.org
> >> >
> >> >> >> wrote:
> >> >> >> >>
> >> >> >> >> I've been trying to recreate these errors, can anyone
share the
> >> >> >> >> specific commands, settings and tools being used?
> >> >> >> >>
> >> >> >> >> I'm trying this with the 3.5M4 builds and I can't
even get the
> >> 'ant'
> >> >> >> >> test to run when Harmony is the bootstrapping JRE
and the JRE
> >> running
> >> >> >> >> the actual tests.
> >> >> >> >>
> >> >> >> >> -Nathan
> >> >> >> >>
> >> >> >> >> On Sat, Jan 10, 2009 at 7:35 AM, Gregory Shimansky
> >> >> >> >> <gshimansky@apache.org> wrote:
> >> >> >> >> > On 7 January 2009 Huang, Eric wrote:
> >> >> >> >> >> Did not cath this one earlier. What is the
> >> jrt.core.tests.builder
> >> >> >> >> >> about? It
> >> >> >> >> >> almost failed completely.
> >> >> >> >> >
> >> >> >> >> > It looks like almost all tests fail with the
same exception
> >> >> message:
> >> >> >> >> >
> >> >> >> >> > Build path contains duplicate
> >> >> >> >> > entry:
> >> >> >> >> >
> >> >> >>
> >> >>
> >>
> 'D:harmony.cc/trunk/working_vm/build/windows_x86_msvc_release/deploy/jdk/jre/bin/default/gc_gen.jar'
> >> >> >> >> > for project 'Project'
> >> >> >> >> >
> >> >> >> >> > Interesting how there is no '/' or '\' after
D: in the path
> >> name.
> >> >> Is
> >> >> >> it
> >> >> >> >> > a
> >> >> >> >> > valid path in win32?
> >> >> >> >> >
> >> >> >> >> >> Eric
> >> >> >> >> >>
> >> >> >> >> >> -----Original Message-----
> >> >> >> >> >> From: chunrong lai [mailto:chunronglai@gmail.com]
> >> >> >> >> >> Sent: Wednesday, January 07, 2009 12:32
PM
> >> >> >> >> >> To: dev@harmony.apache.org
> >> >> >> >> >> Subject: Re: testing for the newer EUT
> >> >> >> >> >>
> >> >> >> >> >> After works on HARMONY-6020 now we get 98.42%
pass rate for
> >> 26416
> >> >> >> test
> >> >> >> >> >> cases when running EUT35 in win32 platform
as below.
> >> >> >> >> >>
> >> >> >> >> >>
> >>  Tests
> >> >> >> >> >> Failures  Errors  Success rate
> >> >> >> >> >>       org.eclipse.ui.tests             
             2143
> >> >> >> >> >> 19                    1            99.07%
> >> >> >> >> >>       org.eclipse.jdt.core.tests.model 
       11138
> >> >> >> >> >> 0                    6            99.95%
> >> >> >> >> >>       org.eclipse.jdt.core.tests.compiler
     10216
> >> >> >> >> >> 17                    0            99.83%
> >> >> >> >> >>       org.eclipse.jdt.core.tests.builder
        195
> >> >> >> >> >> 0                 184             5.64%
> >> >> >> >> >>       org.eclipse.jdt.core.tests.performance
 1
> >> >> >> >> >> 0                    0          100.00%
> >> >> >> >> >>       org.eclipse.team.tests.core      
         17
> >> >> >> >> >> 0                    0          100.00%
> >> >> >> >> >>       org.eclipse.update.tests         
           131
> >> >> >> >> >> 0                    0          100.00%
> >> >> >> >> >>       org.eclipse.core.expressions.tests
      98
> >> >> >> >> >> 0                    0          100.00%
> >> >> >> >> >>       org.eclipse.osgi.tests           
             504
> >> >> >> >> >> 48                 101           70.44%
> >> >> >> >> >>       org.eclipse.core.tests.resources 
        914
> >> >> >> >> >> 7                   29           96.06%
> >> >> >> >> >>       org.eclipse.core.tests.runtime   
         389
> >> >> >> >> >> 1                     0            99.74%
> >> >> >> >> >>       org.eclipse.compare.tests        
          80
> >> >> >> >> >> 0                     0           100.00%
> >> >> >> >> >>       org.eclipse.ant.tests.core       
           85
> >> >> >> >> >> 0                     0           100.00%
> >> >> >> >> >>       org.eclipse.releng.tests         
             5
> >> >> >> >> >> 0                     0           100.00%
> >> >> >> >> >>       org.eclipse.jdt.text.tests       
             500
> >> >> >> >> >> 0                     0           100.00%
> >> >> >> >> >>
> >> >> >> >> >>       Totally:
> 26416
> >> >> >> >> >> 92                 321           98.42%
> >> >> >> >> >>
> >> >> >> >> >>  More details are posted in HARMONY-6062.
> >> >> >> >> >>
> >> >> >> >> >> regards,
> >> >> >> >> >> chunrong
> >> >> >> >> >> Managed Runtime Technology Center, Intel
> >> >> >> >> >>
> >> >> >> >> >> On Sat, Dec 27, 2008 at 3:25 AM, Nathan
Beyer <
> >> ndbeyer@apache.org
> >> >> >
> >> >> >> >> >> wrote:
> >> >> >> >> >> > I posted a comment about this on the
JIRA issue - I think
> >> this
> >> >> is
> >> >> >> >> >> > related to a class loading problem
I found a few weeks
> ago.
> >> The
> >> >> >> >> >> > ClassNotFoundError looked familiar
- I reduced it to a
> >> complex
> >> >> >> >> >> > cyclical class dependency that DRLVM
couldn't load.
> >> >> >> >> >> >
> >> >> >> >> >> > https://issues.apache.org/jira/browse/HARMONY-6020
> >> >> >> >> >> >
> >> >> >> >> >> > On Thu, Dec 25, 2008 at 10:32 PM, chunrong
lai
> >> >> >> >> >> > <chunronglai@gmail.com>
> >> >> >> >> >> >
> >> >> >> >> >> > wrote:
> >> >> >> >> >> > > hi, colleagues:
> >> >> >> >> >> > >    I'd like to update my running
status of EUT35 with
> you.
> >> As
> >> >> >> >> >> > > reported
> >> >> >> >> >> > > in HARMONY-6062, I have not been
able to run EUT35 with
> >> >> Harmony
> >> >> >> >> >> > > (although it
> >> >> >> >> >> >
> >> >> >> >> >> > is
> >> >> >> >> >> >
> >> >> >> >> >> > > fine to run EUT33 with it).
> >> >> >> >> >> > >    The failure can be reproduced
with the long java
> command
> >> >> line
> >> >> >> >> >> > > option
> >> >> >> >> >> > > "java -jar
> >> >> >> >> >> > >
> >> >> >> >> >> > >
> >> >> >>
> >> eclipse\plugins\org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
> >> >> >> >> >> > > -application org.eclipse.test.uitestapplication
-data
> >> >> workspace
> >> >> >> >> >> > > -dev
> >> >> >> >> >> > > bin
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >>
> >> >>
> >>
> formatter=org.apache.tools.ant.taskdefs.optional.junit.XMLJUnitResultForm
> >> >> >> >> >>
> >> >> >> >> >> >
> >> >> >>
> >> >>
> >>
> >atter,d:\eclipse-testing\eclipse\org.eclipse.jdt.text.tests.JdtTextTestSui
> >> >> >> >> >> >te.xml
> >> >> >> >> >> >
> >> >> >> >> >> > > -testPluginName org.eclipse.jdt.text.tests
-className
> >> >> >> >> >> > > org.eclipse.jdt.text.tests.JdtTextTestSuite
-os win32
> -ws
> >> >> win32
> >> >> >> >> >> > > -arch
> >> >> >> >> >> >
> >> >> >> >> >> > x86".
> >> >> >> >> >> >
> >> >> >> >> >> > > I also attached the output file
in the JIRA, where I
> guess
> >> the
> >> >> >> root
> >> >> >> >> >> > > cause are from some Harmony jar
file constrains,
> "!MESSAGE
> >> >> >> Missing
> >> >> >> >> >> > > Constraint: Bundle-RequiredExecutionEnvironment:
> >> JavaSE-1.6".
> >> >> >> >> >> > >    Another interesting point is
that after the test case
> >> had
> >> >> >> >> >> > > successfully runed (so the configuration
phase has been
> >> >> finished)
> >> >> >> >> >> > > with
> >> >> >> >> >> > > RI (with above command), it would
be no problem for
> Harmony
> >> to
> >> >> >> run
> >> >> >> >> >> > > it
> >> >> >> >> >> > > again. This
> >> >> >> >> >> >
> >> >> >> >> >> > somehow
> >> >> >> >> >> >
> >> >> >> >> >> > > supports our guess of some verification
failures in the
> >> >> >> >> >> > > configuration
> >> >> >> >> >> >
> >> >> >> >> >> > phase.
> >> >> >> >> >> >
> >> >> >> >> >> > > On Thu, Dec 18, 2008 at 8:37 PM,
chunrong lai
> >> >> >> >> >> > > <chunronglai@gmail.com>
> >> >> >> >> >> >
> >> >> >> >> >> > wrote:
> >> >> >> >> >> > >> I am running the tests, not
finished yet.
> >> >> >> >> >> > >>
> >> >> >> >> >> > >> Thanks.
> >> >> >> >> >> > >>
> >> >> >> >> >> > >>
> >> >> >> >> >> > >> On Wed, Dec 17, 2008 at 9:28
PM, Tim Ellison
> >> >> >> >> >> > >> <t.p.ellison@gmail.com
> >> >> >> >> >> > >
> >> >> >> >> >> > >wrote:
> >> >> >> >> >> > >>> Are you looking at this
Chunrong?
> >> >> >> >> >> > >>>
> >> >> >> >> >> > >>> Tim Ellison wrote:
> >> >> >> >> >> > >>> > chunrong lai wrote:
> >> >> >> >> >> > >>> >>   So far Harmony
has only EUT3.3 in testing. It
> looks
> >> >> like
> >> >> >> it
> >> >> >> >> >> > >>> >> is
> >> >> >> >> >> >
> >> >> >> >> >> > time
> >> >> >> >> >> >
> >> >> >> >> >> > >>> to
> >> >> >> >> >> > >>>
> >> >> >> >> >> > >>> >> include EUT3.4
now. Your suggestions/comments are
> >> >> welcome.
> >> >> >> >> >> > >>> >
> >> >> >> >> >> > >>> > Skip 3.4 and go straight
to the 3.5 stream tests
> [1].
> >> >> >> >> >> > >>> >
> >> >> >> >> >> > >>> > It would be prudent
to test using the latest
> milestone
> >> >> build
> >> >> >> >> >> > >>> > first
> >> >> >> >> >> >
> >> >> >> >> >> > [2],
> >> >> >> >> >> >
> >> >> >> >> >> > >>> > but if we want to
remain current then catching any
> >> issues
> >> >> >> >> >> > >>> > earlier
> >> >> >> >> >> > >>> > in
> >> >> >> >> >> >
> >> >> >> >> >> > the
> >> >> >> >> >> >
> >> >> >> >> >> > >>> > integration builds
would be the thing to do.
> >> >> >> >> >> > >>> >
> >> >> >> >> >> > >>> > How about running
then using the Apache
> infrastructure,
> >> >> which
> >> >> >> >> >> > >>> > would
> >> >> >> >> >> >
> >> >> >> >> >> > give
> >> >> >> >> >> >
> >> >> >> >> >> > >>> > us better control
of the jobs and insight into the
> >> >> failures?
> >> >> >> >> >> > >>> >
> >> >> >> >> >> > >>> > [1] http://download.eclipse.org/eclipse/downloads/
> >> >> >> >> >> > >>> > [2]
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >>
> >> >>
> >>
> http://download.eclipse.org/eclipse/downloads/drops/S-3.5M3-200810301917/
> >> >> >> >> >> >index.php
> >> >> >> >> >> >
> >> >> >> >> >> > >>> > Regards,
> >> >> >> >> >> > >>> > Tim
> >> >> >> >> >
> >> >> >> >> >
> >> >> >> >> >
> >> >> >> >> > --
> >> >> >> >> > Gregory
> >> >> >> >> >
> >> >> >> >
> >> >> >> >
> >> >> >>
> >> >> >
> >> >>
> >> >
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message