harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sian January" <sianjanu...@googlemail.com>
Subject Re: [vote] Declare r681495 as M7
Date Tue, 19 Aug 2008 14:44:59 GMT
Thanks Mark.  I've just reproduced this on my Windows machine by
switching to Sun's Java 6.  It's happening because they've changed the
javap format in Java 6 to have some extra blank lines in.

Nathan - I can send you a patch that ignores blank lines in the test
if you would like to confirm this, or I can check it in.

I will try to rewrite these tests to be a bit more robust at some
point before the next milestone because we've had a couple of
situations now where differences in javap output or not having javap
available have caused the tests to fail.


On 19/08/2008, Mark Hindess <mark.hindess@googlemail.com> wrote:
>
> Ok.  Using our incomplete javap is probably a bad idea so I've re-run the
> same tests with a sun javap from:
>
>  Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
>  Java HotSpot(TM) 64-Bit Server VM (build 10.0-b23, mixed mode)
>
> And now I get the same errors as you.  Hopefully now Sian can see
> what the problem is.
>
> -Mark.
>
> In message <200808191329.m7JDTR1p017645@d06av03.portsmouth.uk.ibm.com>,
> Mark Hindess writes:
> >
> >
> > I've given Sian access to an ubuntu 64-bit machine.  However, I get
> > different errors - I'm using a javap from a harmony-5.0-jdk debian
> > package that I'm testing for M7.
> >
> > Nathan, what javap are you using?  The output from:
> >
> >   update-alternatives --display javap
> >
> > might help.  Then I should be able to reproduce your environment more
> > accurately.
> >
> > -Mark
> >
> > In message <fc2fc95c0808190402i29238943xec3a7065e155f1ae@mail.gmail.com>,
"Si
> > an
> >  January" writes:
> > >
> > > Ok - thanks.  I have not seen this before and unfortunately I don't
> > > have access to a 64-bit Ubuntu machine to try it out.  It's possibly
> > > happening because your version of javap has a bug in it or prints
> > > things in a different order, but I would need to look at the class
> > > file to find this out.
> > >
> > > Would you be able to run unpack200 manually against HelloWorld.pack
> > > and send me the resulting jar if you have time?  HelloWorld.pack is
> > > under pack200/src/test/resources/org/apache/harmony/pack200/tests.
> > >
> > > Thanks,
> > >
> > > Sian
> > >
> > > On 19/08/2008, Nathan Beyer <ndbeyer@apache.org> wrote:
> > > > Test:           testWithSql
> > > > Class:          org.apache.harmony.unpack200.tests.ArchiveTest
> > > >
> > > > junit.framework.ComparisonFailure: expected:<[ LocalVariableTable:
]>
> > > > but was:<[]>
> > > >        at org.apache.harmony.unpack200.tests.ArchiveTest.testWithSql(Arch
> > iv
> > > eTest.java:94)
> > > >        at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
> > > > Test:   testHelloWorld
> > > > Class:          org.apache.harmony.unpack200.tests.SegmentTest
> > > >
> > > > junit.framework.ComparisonFailure: expected:<[ LocalVariableTable:
]>
> > > > but was:<[]>
> > > >        at org.apache.harmony.unpack200.tests.SegmentTest.testHelloWorld(S
> > eg
> > > mentTest.java:125)
> > > >        at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
> > > >
> > > > On Mon, Aug 18, 2008 at 3:07 AM, Sian January
> > > > <sianjanuary@googlemail.com> wrote:
> > > > > Nathan - would you mind posting more the failure messages for the
> > > > > unpack200 tests?
> > > > >
> > > > > Thanks,
> > > > >
> > > > > Sian
> > > > >
> > > > > On 18/08/2008, Nathan Beyer <ndbeyer@apache.org> wrote:
> > > > >> -1 I'm not able to reproduce the same results on x86_64 Ubuntu
Hardy
> > > > >>
> > > > >> Here are the failures I'm seeing, consistently, in classlib-test.
The
> > > > >> unpack200 test failures concern me.
> > > > >>
> > > > >> error   testGetAttribute
> > > > >>        org.apache.harmony.lang.management.MemoryPoolMXBeanImplTest
> > > > >> error   testGetCollectionUsage
> > > > >>        org.apache.harmony.lang.management.tests.java.lang.management.M
> > em
> > > oryPoolMXBeanTest
> > > > >> failure         testWithSql     org.apache.harmony.unpack200.tests.Arc
> > hi
> > > veTest
> > > > >> failure         testHelloWorld  org.apache.harmony.unpack200.tests.Seg
> > me
> > > ntTest
> > > > >> failure         test_impliesLjava_security_Permission
> > > > >>        tests.api.java.security.PermissionCollectionTest
> > > > >>
> > > > >> Here are the failures I'm seeing, consistently, in jdktools-test.
> > > > >>
> > > > >> error   testDebuggerLaunch001
> > > > >>        org.apache.harmony.jpda.tests.jdwp.DebuggerOnDemand.OnthrowDebu
> > gg
> > > erLaunchTest
> > > > >> error   testDebuggerLaunch002
> > > > >>        org.apache.harmony.jpda.tests.jdwp.DebuggerOnDemand.OnthrowDebu
> > gg
> > > erLaunchTest
> > > > >> error   testDebuggerLaunch003
> > > > >>        org.apache.harmony.jpda.tests.jdwp.DebuggerOnDemand.OnthrowDebu
> > gg
> > > erLaunchTest
> > > > >> error   testDebuggerLaunch004
> > > > >>        org.apache.harmony.jpda.tests.jdwp.DebuggerOnDemand.OnthrowDebu
> > gg
> > > erLaunchTest
> > > > >> error   testAttachConnector001
> > > > >>        org.apache.harmony.jpda.tests.jdwp.MultiSession.AttachConnector
> > Te
> > > st
> > > > >> error   testClearBreakpoint001
> > > > >>        org.apache.harmony.jpda.tests.jdwp.MultiSession.BreakpointTest
> > > > >> error   testMethodEvent001
> > > > >>        org.apache.harmony.jpda.tests.jdwp.MultiSession.MethodEntryExit
> > Te
> > > st
> > > > >> error   testResume      org.apache.harmony.jpda.tests.jdwp.MultiSessio
> > n.
> > > ResumeTest
> > > > >> error   testThreadEnd001
> > > > >>        org.apache.harmony.jpda.tests.jdwp.MultiSession.ThreadEndTest
> > > > >> error   testThreadStart001
> > > > >>        org.apache.harmony.jpda.tests.jdwp.MultiSession.ThreadStartTest
> > > > >>
> > > > >> drlvm-test and drlvm-reg-test are passing.
> > > > >>
> > > > >> -Nathan
> > > > >>
> > > > >> On Fri, Aug 15, 2008 at 8:26 AM, Sian January
> > > > >> <sianjanuary@googlemail.com> wrote:
> > > > >> > Hi everyone,
> > > > >> >
> > > > >> > We have completed a testing cycle for r681495 and evaluated
the resu
> > lt
> > > s [1].
> > > > >> >
> > > > >> > There are some test failures, but most of them are either
intermitte
> > nt
> > > > >> > or were also failing in M6.  However if anyone thinks any
of these
> > > > >> > test failures are blockers and has not yet had a chance
to say, plea
> > se
> > > > >> > speak up now.
> > > > >> >
> > > > >> > Otherwise, shall we declare r681495 as M7?
> > > > >> >
> > > > >> > Thanks,
> > > > >> >
> > > > >> > Sian
> > > > >> >
> > > > >> >
> > > > >> > [1] http://harmony.markmail.org/message/cpfcnslv53doueeg?q=
> > > > >> >
> > > > >> >
> > > > >> > --
> > > > >> > Unless stated otherwise above:
> > > > >> > IBM United Kingdom Limited - Registered in England and Wales
with nu
> > mb
> > > er 741598.
> > > > >> > Registered office: PO Box 41, North Harbour, Portsmouth,
Hampshire P
> > O6
> > >  3AU
> > > > >> >
> > > > >>
> > > > >
> > > > >
> > > > > --
> > > > > Unless stated otherwise above:
> > > > > IBM United Kingdom Limited - Registered in England and Wales with
numbe
> > r
> > > 741598.
> > > > > Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire
PO6
> > 3A
> > > U
> > > > >
> > > >
> > >
> > >
> > > --
> > > Unless stated otherwise above:
> > > IBM United Kingdom Limited - Registered in England and Wales with number 74
> > 15
> > > 98.
> > > Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU
> > >
> >
>
>


-- 
Unless stated otherwise above:
IBM United Kingdom Limited - Registered in England and Wales with number 741598.
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU

Mime
View raw message