harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Fedotov" <alexei.fedo...@gmail.com>
Subject Re: federated build, classlib build - what am I doing wrong
Date Mon, 28 Apr 2008 11:11:28 GMT
Hello, Nathan,
Your sequence is a pretty robust one. I believe that things are enough
and limit myself to fewer commands:

* check out top-level trunk
* ant -Dauto.fetch=true -Dhy.cfg=debug all
* do some class library hacking
* ant -Dbuild.module="archive"  -Dhy.jdk="<dir>/trunk/target/hdk/jdk/" test
(runs tests and regenerates hdk from the target dir which is used by
my debugger)

Thanks!

On Sat, Apr 26, 2008 at 6:46 AM, Nathan Beyer <ndbeyer@apache.org> wrote:
> I've started a fresh workspace on an Ubuntu box and here's what I'm doing.
>
>  * check out top-level trunk
>  * ant populate-source
>  * ant -Dhy.cfg=debug build
>  * rm -rf working_classlib/deploy/*
>  * cp -r targert/hdk/* working_classlib/deploy/*
>  * cd working_classlib
>  * deploy/jdk/jre/bin/java -version
>     Prints version information - works just fine
>  * ant test
>     class library tests run as expected
>  * do some class library hacking
>  * ant build
>  * deploy/jdk/jre/bin/java -version
>     does nothing, just waits, no output
>
>  Shouldn't this work? How are other people doing class library development
>  and continuous rebuilds? I get the same results on Windows.
>
>  -Nathan
>



-- 
With best regards,
Alexei

Mime
View raw message