harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mackie Mathew" <mcclou...@gmail.com>
Subject Re: [harmony-demo-1] Unit test on AWT
Date Sat, 26 Apr 2008 08:53:26 GMT
I added the kernel.jar and luni.jar to the boot classpath... and this is
what happened...

Exception raised while initializing helper class
org/apache/harmony/drlvm/VMHelper
Signal 6 is reported: SIGABRT
Registers:
    EAX: 0x00000000, EBX: 0x00002d42, ECX: 0x00002d42, EDX: 0x00000006
    ESI: 0x00002d42, EDI: 0xb7d01ff4, ESP: 0xbfc8d910, EBP: 0xbfc8d92c
    EIP: 0xffffe410

Crashed module:
Unknown address 0xffffe410

Working directory:
/home/mackie/harmony/working_classlib/modules/awt

Command line:
/home/mackie/harmony/target/hdk/jdk/jre/bin/java
-Xbootclasspath:/home/mackie/harmony/target/hdk/jdk/jre/bin/default/kernel.jar:/home/mackie/harmony/target/hdk/jdk/jre/lib/boot/luni.jar
-classpath
/home/mackie/harmony/working_classlib/modules/awt/bin/main/common:/home/mackie/harmony/working_classlib/modules/awt/bin/test/api:/home/mackie/harmony/working_classlib/modules/awt/bin/test/unix:/home/mackie/harmony/working_classlib/modules/awt/bin/test/windows:/home/mackie/harmony/working_classlib/modules/awt/bin/test/boot:/home/mackie/harmony/working_classlib/modules/awt/bin/main/windows:/home/mackie/harmony/working_classlib/modules/awt/bin/main/linux:/home/mackie/harmony/working_classlib/modules/awt/src/test/api/resources:/home/mackie/harmony/working_classlib/modules/accessibility/bin/main:/home/mackie/harmony/working_classlib/modules/accessibility/bin/test:/home/mackie/harmony/working_classlib/modules/accessibility/bin:/home/mackie/harmony/working_classlib/modules/beans/bin/main:/home/mackie/harmony/working_classlib/modules/beans/bin/test_support:/home/mackie/harmony/working_classlib/modules/beans/bin/test:/home/mackie/harmony/working_classlib/modules/beans/bin/test-internal:/home/mackie/harmony/working_classlib/modules/applet/bin/main:/home/mackie/harmony/working_classlib/modules/applet/bin/test:/home/mackie/harmony/working_classlib/modules/applet/bin:/home/mackie/harmony/working_classlib/modules/luni/bin/main:/home/mackie/harmony/working_classlib/modules/luni/bin/test:/home/mackie/harmony/working_classlib/modules/luni-kernel/bin/main:/home/mackie/harmony/target/hdk/jdk/jre/lib/boot/icu4j_3.8/icu4j-3_8.jar:/home/mackie/harmony/target/hdk/jdk/jre/lib/boot/icu4j_3.8/icu4j-charsets-3_8.jar:/home/mackie/harmony/working_classlib/modules/annotation/bin/main:/home/mackie/harmony/working_classlib/modules/annotation/bin/test:/home/mackie/harmony/working_classlib/modules/annotation/bin:/home/mackie/harmony/working_classlib/modules/security/bin/main:/home/mackie/harmony/working_classlib/modules/security/bin/test:/home/mackie/harmony/working_classlib/modules/security-kernel/bin/main:/home/mackie/harmony/working_classlib/modules/security-kernel/bin:/home/mackie/harmony/working_classlib/modules/math/bin/main:/home/mackie/harmony/working_classlib/modules/math/bin/test:/opt/eclipse/plugins/org.junit_3.8.2.v200706111738/junit.jar:/home/mackie/harmony/working_classlib/modules/nio/bin/test:/home/mackie/harmony/working_classlib/modules/nio/bin/main:/home/mackie/harmony/working_classlib/modules/nio_char/bin/main:/home/mackie/harmony/working_classlib/modules/nio_char/bin/test:/home/mackie/harmony/working_classlib/support/bin:/home/mackie/harmony/working_classlib/modules/archive/bin/main:/home/mackie/harmony/working_classlib/modules/archive/bin/test:/home/mackie/harmony/working_classlib/modules/auth/bin/main:/home/mackie/harmony/working_classlib/modules/auth/bin/test:/home/mackie/harmony/working_classlib/modules/crypto/bin/main:/home/mackie/harmony/working_classlib/modules/crypto/bin/test/api:/home/mackie/harmony/working_classlib/modules/crypt



Loaded modules:


VM attached threads:

--->[0xb7a716c0]

Stack trace:
  0: ?? (??:-1)
  1: ?? (??:-1)
  2: ?? (??:-1)
  3: ?? (??:-1)
  4: ?? (??:-1)
  5: ?? (??:-1)
  6: ?? (??:-1)
  7: ?? (??:-1)
  8: ?? (??:-1)
  9: ?? (??:-1)
 10: ?? (??:-1)
<end of stack trace>

On Sat, Apr 26, 2008 at 12:57 PM, Alexei Fedotov <alexei.fedotov@gmail.com>
wrote:

> Tharindu,
> Have you added kernel.jar to the project classpath?
> Have you added the project classpath to the boot classpath in the launch
> dialog?
>
> Thanks!
>
> On Sat, Apr 26, 2008 at 11:24 AM, Mackie Mathew <mccloud35@gmail.com>
> wrote:
> > I added the awt project under bootstrap entries in the run dialog. Now
> both
> >  Sun JDK and Harmony give the following exception:
> >
> >  Error occurred during initialization of VM
> >
> > java/lang/NoClassDefFoundError: java/lang/Object
> >
> >
> >
> > On Fri, Apr 25, 2008 at 11:52 AM, Andrey Pavlenko <
> >  andrey.a.pavlenko@googlemail.com> wrote:
> >
> >  > You should add the tests to the boot class path in the Eclipse Run
> dialog.
> >  >
> >  > On Fri, Apr 25, 2008 at 10:05 AM, Mackie Mathew <mccloud35@gmail.com>
> >  > wrote:
> >  >
> >  > > I'm trying to run the the tests on AWT. When I use the Sun JDK it
> gives
> >  > a
> >  > > security violation, due to the awt package name being used.
> >  > >
> >  > > java.lang.SecurityException: Prohibited package name: java.awt
> >  > >    at java.lang.ClassLoader.preDefineClass(ClassLoader.java:479)
> >  > >    at java.lang.ClassLoader.defineClass(ClassLoader.java:614)
> >  > >    at
> >  > >
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
> >  > >    at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
> >  > >    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
> >  > >    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
> >  > >    at java.security.AccessController.doPrivileged(Native Method)
> >  > >    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> >  > >    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> >  > >    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
> >  > >    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> >  > >    at
> >  > >
> >  > >
> >  >
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClass(RemoteTestRunner.java:683)
> >  > >    at
> >  > >
> >  > >
> >  >
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClasses(RemoteTestRunner.java:425)
> >  > >    at
> >  > >
> >  > >
> >  >
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:445)
> >  > >    at
> >  > >
> >  > >
> >  >
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
> >  > >    at
> >  > >
> >  > >
> >  >
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
> >  > >    at
> >  > >
> >  > >
> >  >
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
> >  > >
> >  > > When Harmony is used as the JDK, the following error occurs:
> >  > >
> >  > > java/lang/NoClassDefFoundError : java/lang/Object
> >  > >
> >  > >
> >  > > How can these tests be run? Im using Eclipse as the IDE to run the
> >  > tests.
> >  > >
> >  > > --
> >  > > Regards,
> >  > >
> >  > > Tharindu
> >  > >
> >  >
> >
> >
> >
> >  --
> >  Regards,
> >
> >  Tharindu
> >
>
>
>
> --
> With best regards,
> Alexei
>



-- 
Regards,

Tharindu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message