harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: Issue / workaround - running Maven2 using Apache Harmony
Date Wed, 16 Apr 2008 14:42:20 GMT
FYI, Status:

Apache XmlSchema - Had issue with Maven needing another switch
- https://issues.apache.org/jira/browse/HARMONY-5745

Apache Neethi - Got rid of sun.misc.Service using code from Batik
- https://issues.apache.org/jira/browse/WSCOMMONS-322
- http://svn.apache.org/viewcvs?view=rev&rev=648423

Apache Woden - Filed bug in FileURLConnection
- https://issues.apache.org/jira/browse/HARMONY-5737

Apache Axiom - Filed a patch in ImageIO
- https://issues.apache.org/jira/browse/HARMONY-5738

Apache Axis2 - Checked in one fix in Kernel tests
- http://svn.apache.org/viewvc?view=rev&revision=648700

In the Axis2/Kernel issue, the problem is when i use the following piece of code

    public static void main(String[] args) throws Exception {
        Class clazz = Class.forName(args[0]);
        Field[] fields = clazz.getDeclaredFields();
        for (int i = 0; i < fields.length; i++) {
            Field field = fields[i];
            System.out.println("Field - Name        : " + field.getName());
            System.out.println("      - Description : " + field.toString());
            System.out.println("      - Type        : " +
field.getType().getCanonicalName());
        }
    }

I get a different output with Sun/IBM JDK1.5/1.6 compared to Harmony.
This is not for a trivial class, but for one class in particular in
Axis2 (org.apache.axis2.context.MessageContext).

Still a long way to go to get Axis2 working under Harmony, just saw
failures in adb-codegen module.

thanks,
dims

On Wed, Apr 16, 2008 at 4:03 AM, Tim Ellison <t.p.ellison@gmail.com> wrote:
> It would be good to capture this in a JIRA for tracking.  I don't know what
> Surefire does, so if there are any Maven types lurking it would be good to
> get their help with this too (otherwise I'll go over there and ask).
>
>  To set this mail in context:
>  There is a discussion underway on the ASF members mailing list about
> running more of Apache's applications on Harmony, where I have encouraged
> people to try M5 and report successes|bugs to this list.
>  I'm sure such reports will get people's attention as it is good to see
> Harmony being put to good use.
>
>  Thanks Dims for trying maven2 and finding this!
>
>  Regards,
>  Tim
>
>
>
>  Davanum Srinivas wrote:
>
> > FYI, just set JAVA_HOME as usual and run ?mvn clean install?. But there?s
> a gotcha. You may see the following issue when
> > surefire tries to run the tests.
> >
> > [INFO] [resources:testResources]
> > [INFO] Using default encoding to copy filtered resources.
> > [INFO] [compiler:testCompile]
> > [INFO] Compiling 58 source files to
> /home/dims/XmlSchema/target/test-classes
> > [INFO] [surefire:test]
> > [INFO] Surefire report directory:
> /home/dims/XmlSchema/target/surefire-reports
> > Uncaught exception in main:
> > java.lang.ClassNotFoundException:
> org.apache.maven.surefire.booter.SurefireBooter
> > at java.net.URLClassLoader.findClass(URLClassLoader.java:894)
> > at java.lang.ClassLoader.loadClass(ClassLoader.java:593)
> > at java.lang.ClassLoader$SystemClassLoader.loadClass(ClassLoader.java:981)
> > at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
> > at org.apache.harmony.vm.JarRunner.main(JarRunner.java:72)
> > [INFO] ????????????????????????
> > [ERROR] BUILD FAILURE
> > [INFO] ????????????????????????
> >
> > If you do, then just set your MAVEN_OPTS as follows and run ?mvn clean
> install? again.
> >
> > set MAVEN_OPTS=-Dsurefire.useSystemClassLoader=false
> >
> > More information about this switch can be found at:
> >
> http://docs.codehaus.org/display/MAVENUSER/Classloading+and+Forking+under+Maven+Surefire
> >
> > Not sure if this is a harmony bug. Anyone wanna look?
> >
> > thanks,
> > dims
> >
>



-- 
Davanum Srinivas :: http://davanum.wordpress.com

Mime
View raw message