harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Fedotov" <alexei.fedo...@gmail.com>
Subject Re: [classlib][archive] Non-UTF8 character in manifest during confluence startup (HARMONY-5662)
Date Fri, 28 Mar 2008 12:38:39 GMT
Alexei,
Could you please dump "buf" buffer from InitManifest constructor to
check if it really contains a null character? If it does, we should
think how to ignore it smoothly.

Thank you in advance.

On Fri, Mar 28, 2008 at 3:15 PM, Alexei Zakharov
<alexei.zakharov@gmail.com> wrote:
> I'd like to note here that I don't remember any problems with
>  manifests loading during confluence startup a couple of months ago
>  (however, there were other problems). It looks like manifest parsing
>  routines were significantly updated since then.
>
>  Regards,
>  Alexei
>
>  2008/3/28, Alexei Fedotov <alexei.fedotov@gmail.com>:
>
>
> > Alexei's problem (introduced by a patch from [1]) is fixed in my code.
>  >  He faced another one though.
>  >
>  >  [1] http://issues.apache.org/jira/browse/HARMONY-5473
>  >
>  >
>  >
>  >
>  >  On Fri, Mar 28, 2008 at 2:41 PM, Tim Ellison <t.p.ellison@gmail.com> wrote:
>  >  > Tim Ellison wrote:
>  >  >  > I just committed code in this area (at r641928) so it may indeed be
a
>  >  >  > regression.  Looking...
>  >  >
>  >  >  Sorry Alexei, just noticed that your version under test was r640865.
>  >  >
>  >  >  Given the recent changes is it possible for you to retry on a later
>  >  >  version >r641928 since the failing code has been replaced.
>  >  >
>  >  >  Thanks,
>  >  >  Tim
>  >  >
>  >  >
>  >
>  >
>  >
>  >
>  > --
>  >  With best regards,
>  >
>  > Alexei
>  >
>



-- 
With best regards,
Alexei

Mime
View raw message