harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Qiu" <sean.xx....@gmail.com>
Subject Re: [build] build errors ubuntu
Date Wed, 26 Mar 2008 02:18:02 GMT
Maybe you  need install these packages

sudo apt-get install liblcms1-dev
sudo  apt-get install libpng12-dev
sudo  apt-get install libjpeg62-dev
sudo  apt-get install build-essencial
sudo  apt-get install libx11-dev
 sudo  apt-get install libxft-dev
sudo  apt-get install libxext-dev


2008/3/25, Maksim Ananjev <maksim.ananjev@gmail.com>:
> Seem that libXext is missing.
>  Maybe you should try apt-get install libXext.
>
>  Just a guess
>
>
>  On 3/25/08, "Edmundo López B." <edmundo@lopezbobeda.net> wrote:
>  > Hello,
>  >
>  > I'm still trying to compile harmony this time under ubuntu and I get
>  > the following error:
>  >
>  >       [exec] cc -DLINUX -DLINUX_X86 -DHYX86 -DIPv6_FUNCTION_SUPPORT -
>  > D_REENTRANT -I/home/mundacho/gsoc/trunk/working_classlib/deploy/
>  > include -I/home/mundacho/gsoc/trunk/working_classlib/deploy/jdk/
>  > include -I. -I../shared/ -Icommon -I../shared//include -I/home/
>  > mundacho/gsoc/trunk/working_classlib/deploy/../depends/libs/build/png -
>  > I/usr/X11R6/include -I/usr/include -Iinclude -fpic -march=pentium3 -
>  > ggdb -O0    -c -o LockingKeys.o LockingKeys.cpp
>  >       [exec] cp /home/mundacho/gsoc/trunk/working_classlib/deploy/../
>  > depends/libs/build/png/libpng.linux.x86 libpng.a
>  >       [exec] echo "HYGL_0.1 {" >libgl.exp
>  >       [exec] echo "  global :" >>libgl.exp
>  >       [exec] sed -e's/^/    /;s/$/;/' <exports.txt >>libgl.exp
>  >       [exec] echo "  local : *;" >>libgl.exp
>  >       [exec] echo "};" >>libgl.exp
>  >       [exec] cc -shared -Wl,-soname=libgl.so -Wl,--version-
>  > script,libgl.exp   -o ../libgl.so \
>  >       [exec]     ../shared//blitter.o ../shared//gifdecoder.o ../
>  > shared//LUTTables.o ../shared//pngdecoder.o ../shared//
>  > SurfaceDataStructure.o gl.o XBlitter.o XGraphics2D.o LockingKeys.o
>  > libpng.a \
>  >       [exec]     -Xlinker --start-group /home/mundacho/gsoc/trunk/
>  > working_classlib/deploy/lib/libhycommon.a /home/mundacho/gsoc/trunk/
>  > working_classlib/deploy/jdk/jre/bin/libhythr.so /home/mundacho/gsoc/
>  > trunk/working_classlib/deploy/jdk/jre/bin/libhysig.so /home/mundacho/
>  > gsoc/trunk/working_classlib/deploy/lib/libhyzip.a /home/mundacho/gsoc/
>  > trunk/working_classlib/deploy/jdk/jre/bin/libhyzlib.so /home/mundacho/
>  > gsoc/trunk/working_classlib/deploy/lib/libhypool.a /home/mundacho/gsoc/
>  > trunk/working_classlib/deploy/lib/libhyfdlibm.a /home/mundacho/gsoc/
>  > trunk/working_classlib/deploy/lib/libvmi.so -Xlinker --end-group \
>  >       [exec]     -lc -lm -ldl -lstdc++ -L/usr/X11R6/lib -lX11 -lXft -
>  > lXext -lXtst
>  >       [exec] /usr/bin/ld: cannot find -lXext
>  >       [exec] collect2: ld returned 1 exit status
>  >       [exec] make: *** [../libgl.so] Error 1
>  >
>  > BUILD FAILED
>  > /home/mundacho/gsoc/trunk/build.xml:349: The following error occurred
>  > while executing this line:
>  > /home/mundacho/gsoc/trunk/working_classlib/build.xml:148: The
>  > following error occurred while executing this line:
>  > /home/mundacho/gsoc/trunk/working_classlib/make/build-native.xml:82:
>  > The following error occurred while executing this line:
>  > /home/mundacho/gsoc/trunk/working_classlib/modules/awt/build.xml:183:
>  > The following error occurred while executing this line:
>  > /home/mundacho/gsoc/trunk/working_classlib/make/properties.xml:492:
>  > exec returned: 2
>  >
>  > can anyone help me? Thanks in advance,
>  >
>  > Edmundo López B.
>  > edmundo@lopezbobeda.net
>  >
>  >
>  >
>  >
>  >
>
>
>
> --
>
> Maksim
>


-- 
Best Regards
Sean, Xiao Xia Qiu

China Software Development Lab, IBM

Mime
View raw message