harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stepan Mishura" <stepan.mish...@gmail.com>
Subject Re: ant version support
Date Mon, 31 Mar 2008 05:36:21 GMT
On 3/31/08, Nathan Beyer <ndbeyer@apache.org> wrote:
> If there is enough support, we can add something like this to the
> top-level scripts to give notice -
>
> <target name="ant-version-check" description="ant version check">
> <fail message="You must use Ant 1.7.0">
> <condition>
> <not>
> <contains string="${ant.version}" substring="1.7.0"/>
> </not>
> </condition>
> </fail>
> </target>
>

Our BTI scripts was not tested with v1.7. So I'm 100% not sure that
moving to the new ANT's version will be smooth. Also currently I'm
refactoring the scripts and need some  to test them with ANT 1.7. Is
it possible to wait with the change and let me to complete refactoring
and testing with 1.7? (I do hope to complete refactoring this week,
and for testing I need ~ 1-2 days). Does this work for you?

Thanks,
Stepan.

> -Nathan
>
> On Sat, Mar 29, 2008 at 8:45 PM, Nathan Beyer <ndbeyer@apache.org> wrote:
> > There seem to be all sorts of quirks between Ant v1.6.5 and Ant
> >  v1.7.0. The most recent I just ran into was the DRLVM cunit tests
> >  failing because of the use of 'refid' instead of 'id' in the
> >  'includepath' element [1].
> >
> >  Since v1.7 has been out for quite a while now and most unix and linux
> >  variants are shipping that version as the default, I'd like to suggest
> >  that we move to v1.7 as the officially supported version. This would
> >  essentially be updating all doc (web site, readmes, etc) and perhaps a
> >  minor code pause to facilitate the switch.
> >
> >  thoughts?
> >
> >  -Nathan
> >
> >  [1] https://sourceforge.net/tracker/?func=detail&atid=416920&aid=1626443&group_id=36177
> >
>

Mime
View raw message