harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lyon <ustcl...@gmail.com>
Subject Re: [build] Re: build problem
Date Sun, 02 Mar 2008 11:28:50 GMT
Tim Ellison 写道:
> lyon wrote:
>   
>> I build the harmony.
>> the error as follows.
>>
>> I have found that the "I_64" was defined in the file "hycomp.h",
>> The hythread.h had included the "hycomp.h".
>>
>> why didn't the programm know the identifier "I_64"?
>>
>> make-all:
>>
>> -build-native:
>> [echo] Making "" in
>> C:\trunk\working_classlib\modules\portlib\src\main\native/common/windows
>> [exec] cl -c -W3 -DCRTAPI1=_cdecl -DCRTAPI2=_cdecl -nologo -FIsehmap.h
>> -D_X86_=1 -D_WIN95 -D_WIN32_WINDOWS=0x0400 -D_WIN32_IE=0x0500 -DWIN
>> CURE_NO_DEPRECATE -D_CRT_SECURE_NO_WARNINGS -D_SCL_SECURE_NO_DEPRECATE
>> -D_DLL -D_MT -D_WINSOCKAPI_ /IC:\trunk\working_classlib\deploy\include /
>> .\shared\ -Fo..\shared\libglob.obj ..\shared\libglob.c
>> [exec] libglob.c
>> [exec] C:\trunk\working_classlib\deploy\include\hythread.h(107) : error
>> C2146: syntax error : missing ')' before identifier 'millis'
>>     
>
> <snip>
>
> Hi lyon,
>
> What compiler and OS are you building on?
>
> Your compile line looks a bit different to mine. You don't have -DWIN32
> defined.
>
> Thanks,
> Tim
>
>   
I think I have solve the problem.

When execute the command 'cl', it was wrong. It have to config the Microsoft Visual Studio
.NET environment.
My Microsoft Visual Studio .NET is 2005,so it has something wrong .



Mime
View raw message