harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer" <nbe...@gmail.com>
Subject Re: libXtst is a requisite
Date Sat, 29 Mar 2008 13:57:12 GMT
Patches are welcome - even for doc!

Also, I think a check can be added to the scripts to look for this.
There are other checks for libpng, etc that print out a nice error
that says something about trying "apt-get" or "yum".

-Nathan

On Sat, Mar 29, 2008 at 3:56 AM, Senaka Fernando <senakafdo@gmail.com> wrote:
> Hi Pavel,
>
>  I guess that the apt-get does solve it. Soft linking should be avoided,
>  since you might step into version issues. Basically in the C/C++ world, if
>  we don't find any lib, we'd rather fetch the dev packages. Same applies for
>  headers. In some situations you might need the utils, or extras too.
>
>  Also, I didn't notice this conversation previously. Anyhow, I believe that
>  it should be added as a Basic pre-requisite. That is why I sent this mail.
>
>  Regards,
>  Senaka
>
>  On Sat, Mar 29, 2008 at 2:05 PM, Pavel Rebriy <pavel.rebriy@gmail.com>
>  wrote:
>
>
>
>  > Please look at *"**[build] build errors ubuntu" *branch for details.
>  >
>  > On 29/03/2008, Senaka Fernando <senakafdo@gmail.com> wrote:
>  > >
>  > > Hi all,
>  > >
>  > > While building Harmony, with the 'all' option,
>  > >
>  > > It seems that the Xtst library is required.
>  > >
>  > > You will have to install libxtst-dev.
>  > >
>  > > I'm having a Ubuntu 7.10 system, and have installed all the Basic
>  > > pre-requisites
>  > >
>  > > Regards,
>  > >
>  > > Senaka
>  > >
>  >
>  >
>  >
>  > --
>  > Best regards,
>  > Pavel Rebriy
>  >
>

Mime
View raw message