harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer" <nbe...@gmail.com>
Subject Re: [build] missing common_resources when building harmony
Date Wed, 05 Mar 2008 01:52:21 GMT
Hmm ... the SVN clients are generally upwards compatible for the most
part. You didn't happen to be mixing use of SVN versions on the same
working copy, did you?

2008/3/4 Maksim Ananjev <maksim.ananjev@gmail.com>:
> Guys,
>
>  Thanks for your attention and suggestions! It turned out to be the
>  matter of old subversion client. After upgrading the client, the
>  problem disappeared. It looks like magic to me, but it works.
>
>  Maybe it makes sense to teach build script to check svn version and
>  give at least a warning if it's less then 1.4. This can possibly save
>  time.
>
>
>
>  2008/3/3 Pavel Pervov <pmcfirst@gmail.com>:
>
> > The problem here is common_resources that resides in enhanced/trunk is
>  >  linked with common_resources instead of common_resources/.trunk.
>  >  Thus federated build won't work until you manually switch
>  >  common_resources to new location.
>  >
>  >  I'm sure there is a way to correct enhanced/trunk and I'm trying to
>  >  find one now. Any hints?
>  >
>  >
>  >
>
>
> > Pavel.
>  >
>  >  On 3/3/08, Maksim Ananjev <maksim.ananjev@gmail.com> wrote:
>  >  > Pavel,
>  >  >
>  >  > I do not perform special checkout for common_resources. I just use:
>  >  > svn co http://svn.apache.org/repos/asf/harmony/enhanced/trunk as it is
>  >  > recommended in the documentation.
>  >  >
>  >  > Do I need to checkout anything form a separate location?
>  >  >
>  >  >
>  >  > 2008/3/3 Pavel Pervov <pmcfirst@gmail.com>:
>  >  > > Maksim,
>  >  > >
>  >  > >  What URL you are checking out as common_resources?
>  >  > >
>  >  > >  Pavel.
>  >  > >
>  >  > >
>  >  > >
>  >  > > On 3/3/08, Maksim Ananjev <maksim.ananjev@gmail.com> wrote:
>  >  > >  > George, thanks for your remark.
>  >  > >  >
>  >  > >  > I have not switched anything. I've deleted and svn'ed up
>  >  > >  > "common_resources". Shouldn't cause the same result? If not, could
you
>  >  > >  > please say where i should switch common_resources?
>  >  > >  >
>  >  > >  > On Mon, Mar 3, 2008 at 11:53 AM, Gregory Shimansky
>  >  > >  > <gshimansky@apache.org> wrote:
>  >  > >  > > On 3 марта 2008 Maksim Ananjev wrote:
>  >  > >  > >
>  >  > >  > > > Alexey,
>  >  > >  > >  >
>  >  > >  > >  > I have already done that with no result, i.e. the result
is the same
>  >  > >  > >  > to what I had described.
>  >  > >  > >
>  >  > >  > >
>  >  > >  > > Some time ago there was a switch in common resources so that
the URL has to
>  >  > >  > >  point to common_resources/trunk. In one of my working directories
I forgot to
>  >  > >  > >  do the switch and had a similar problem for a while until
I figured what's
>  >  > >  > >  going on. Are you sure you've done svn switch on your copy
of
>  >  > >  > >  common_resources?
>  >  > >  > >
>  >  > >  > >
>  >  > >  > >
>  >  > >  > > > On Mon, Mar 3, 2008 at 11:20 AM, Alexey Varlamov
>  >  > >  > >  >
>  >  > >  > >  > <alexey.v.varlamov@gmail.com> wrote:
>  >  > >  > >  > > The reason is simple, your common_resources must
be vastly outdated.
>  >  > >  > >  > >  All you need is "cd common_resources; svn up"
>  >  > >  > >  > >  Probably we need to fix the error message to
cover such cases.
>  >  > >  > >  > >
>  >  > >  > >  > >  --
>  >  > >  > >  > >  Alexey
>  >  > >  > >  > >
>  >  > >  > >  > >  2008/3/3, Maksim Ananjev <maksim.ananjev@gmail.com>:
>  >  > >  > >  > > > Folks,
>  >  > >  > >  > > >
>  >  > >  > >  > >  > I cannot build the atest revision of drlvm.
When I say "ant" in the
>  >  > >  > >  > >  > working_vm directory or in the "trunk" directory,
I get the following
>  >  > >  > >  > >  > error:
>  >  > >  > >  > >  >
>  >  > >  > >  > >  > BUILD FAILED
>  >  > >  > >  > >  > /export/users/miananje/trunk/build.xml:421:
The following error
>  >  > >  > >  > >  > occurred while executing this line:
>  >  > >  > >  > >  > /export/users/miananje/trunk/working_vm/build.xml:24:
The following
>  >  > >  > >  > >  > error occurred while executing this line:
>  >  > >  > >  > >  > /export/users/miananje/trunk/working_vm/make/properties.xml:52:
>  >  > >  > >  > >  > Primary dependency is missing: common_resources.
>  >  > >  > >  > >  >        You need to check it out from SVN
repository or specify it's
>  >  > >  > >  > >  > location: ant -Dcommon.resources.loc=path
>  >  > >  > >  > >  >
>  >  > >  > >  > >  >
>  >  > >  > >  > >  > I tried the following steps:
>  >  > >  > >  > >  >
>  >  > >  > >  > >  > 1. specify the location to common_resources
folder in ant arguments
>  >  > >  > >  > >  > 2. delete common_resources folder, svn up,
and run ant
>  >  > >  > >  > >  > 3. run ant clean
>  >  > >  > >  > >  > 4. run ant -Dauto-fetch=true
>  >  > >  > >  > >  >
>  >  > >  > >  > >  > But always got the same error.
>  >  > >  > >  > >  >
>  >  > >  > >  > >  > Please help.
>  >  > >  > >  > >  >
>  >  > >  > >  > >  > --
>  >  > >  > >  > >  > Maksim
>  >  > >  > >
>  >  > >  > >
>  >  > >  > >
>  >  > >  > >  --
>  >  > >  > >  Gregory
>  >  > >  > >
>  >  > >  >
>  >  > >  >
>  >  > >  >
>  >  > >  > --
>  >  > >  > Maksim
>  >  > >  >
>  >  > >
>  >  > >
>  >  > >
>  >  > >
>  >  > > --
>  >  > >  Pavel Pervov,
>  >  > >  Intel Enterprise Solutions Software Division
>  >  > >
>  >  >
>  >  >
>  >  >
>  >  > --
>  >  > Maksim
>  >  >
>  >
>  >
>  >  --
>  >
>  >
>  > Pavel Pervov,
>  >  Intel Enterprise Solutions Software Division
>  >
>
>
>
>  --
>  Maksim
>
Mime
View raw message