harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Zakharov" <alexei.zakha...@gmail.com>
Subject Re: [build-test] new ant target
Date Tue, 25 Mar 2008 14:25:08 GMT
I've tried this, but it reported

svn: 'https://svn.apache.org/repos/asf/harmony/enhanced/buildtest/trunk/tests/struts_test'
is not the same repository as
'http://svn.apache.org/repos/asf'

Now I recall that I probably used "--relocate" switch in the same
situation in the past. However, yesterday I wasn't smart enough.
Anyway, I don't see much reason in setting the default location to
"http://svn.apache.org/blah/blah/blah". Is this a special feature of
our BTI? IMO Apache's svn server can afford using HTTPS in case if our
CC is not hitting it every two seconds.

Thanks,
Alexei

2008/3/25, Tim Ellison <t.p.ellison@gmail.com>:
> Alexei Zakharov wrote:
>  > Thanks Stepan. By the way, I also noticed that by default all test
>  > sources are downloaded from
>  >
>  > http://svn.apache.org/repos/....
>  >
>  > This is a bit inconvenient if you are a committer and trying to commit
>  > changes in tests. Because svn refuses to commit anything if the
>  > repository URL doesn't start with HTTPS. So yesterday I had to
>  > recheckout all sources in order to commit a trivial change to struts
>  > tests.
>
>
> In cases like this, where you know it is the same resources at a
>  different URL, svn switch is your friend.
>
>  Regards,
>
> Tim
>
>
>
>  > 2008/3/25, Stepan Mishura <stepan.mishura@gmail.com>:
>  >> On 3/22/08, Stepan Mishura <stepan.mishura@gmail.com> wrote:
>  >>  > On 3/21/08, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
>  >>  > > Hi Stepan,
>  >>  > >
>  >>  > > Today I was trying to update the buildtest workspace and found that
>  >>  > > you've made several changes to it. I tried to read README.txt but
this
>  >>  > > was not very helpful since the file itself looks outdated. Then
from
>  >>  > > svn logs I understand that you've added new 'install' target to
main
>  >>  > > build.xml . So what is the correct sequence now
>  >>  > >
>  >>  > > ant install
>  >>  > > ant -Dtest.suites=struts_test setup
>  >>  > > ant -Dtest.suites=struts_test run
>  >>  > >
>  >>  >
>  >>  > Yes, this is correct sequence now, but install should has
>  >>  > -Dtest.suites=struts_test param too.
>  >>  >
>  >>  > I'm sorry that I didn't warned about the change and not updated
>  >>  > README. Currently I'm working on infra's improvements to make work
>  >>  > flow more simple/transparent and resolve several issues mentioned on
>  >>  > the dev-list. Please be patient to me if I broke something or the doc
>  >>  > is inconsistent.
>  >>
>  >>
>  >> BTW, if you find something broken please let me know.
>  >>  Also in this case you may use BTI's svn revision < 639550 - it should work.
>  >>
>  >>  Thanks,
>  >>
>  >> Stepan.
>  >>
>  >>
>  >>  > After I complete improvements I'm going to align the
>  >>  > README and the page on the web-site.
>  >>  >
>  >>  > Thanks,
>  >>  > Stepan.
>  >>  >
>  >>  > > ?
>  >>  > >
>  >>  > > Regards,
>  >>  > > Alexei
>  >
>

Mime
View raw message