harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Kewl" <j...@kewlstuff.co.za>
Subject Harmony Dev Environment On XP?
Date Sat, 01 Mar 2008 21:04:25 GMT
.... this is what I did...


-- svn co http://svn.apache.org/repos/asf/harmony/enhanced/trunk
-- ant -Dauto.fetch=true
-- ant populate-src

Then to make it a little easier

I installed Visual Studio 2005 and MASM
Then I run this script
@echo off

 if not exist "C:\Program Files\Microsoft Visual Studio 8\VC\vcvarsall.bat" 
goto missing
 echo call "C:\Program Files\Microsoft Visual Studio 8\VC\vcvarsall.bat"
 call "C:\Program Files\Microsoft Visual Studio 8\VC\vcvarsall.bat"

 @set PATH=C:\Program Files\Microsoft Visual Studio 8\VC\bin;%PATH%
 @set INCLUDE=C:\Program Files\Microsoft Visual Studio 
8\VC\Include;%INCLUDE%
 @set LIB=C:\Program Files\Microsoft Visual Studio 8\VC\Lib;%LIB%

 call ".\eclipse.exe"

 goto :eof

 :missing
 echo Missing file
 echo "C:\Program Files\Microsoft Visual Studio 8\VC\vcvarsall.bat"
 goto :eof

Then I Load E:\Harmony\working_classlib\build.xml in eclipse... can see all 
the tasks and run them

-- ant fetch-depends

At this stage Xerces gives trouble.... the file size that comes in is 4 
megs, the one on the site is 6 megs... ? so MD5 file fails unless done 
manually

-- build

Then is complains about cant compile something in /concurrent... so I 
downloaded the "Windows Src" pack on the site found the missing folder
and the Java compiles...

When it tries to compile the native stuff it complains about a double 
declaration of _Win_NT_Ver in the a threading module... I change the Window 
header file that was
getting upset to NT4... forget the module off hand

Then it gets passed that compiles a few files and gets stuck here
hyerrorhelpers.c(122) : warning C4013: 'sprintf' undefined; assuming extern 
returning int
I started fiddling with code... adding window header files to Harmony code 
but that really makes in mad ;)

Then I took the whole of the Windows download and copied it over the SVN 
download... in the hope headers would fix...
Now its is really screwed... wont even get through the Java compile...
I get an error I have no idea what it means
BUILD FAILED
E:\Harmony\working_classlib\build.xml:113: The following error occurred 
while executing this line:
E:\Harmony\working_classlib\make\build-java.xml:120: 
java.lang.reflect.InvocationTargetException

I think the only place to start is to setup an environment that works on 
XP... the way I'm trying seems not to work...
Maybe there  is a way to tell eclipse to use another compiler dont know, 
build script is looking for nmake and thats the only way I could
figure out to give it one... ?

... me stuck ;)


Mime
View raw message