harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Fedotov" <alexei.fedo...@gmail.com>
Subject Re: [build] ant target naming consistency
Date Thu, 14 Feb 2008 13:04:54 GMT
We may think of unifying terms as well, e.g. use "src"/"bin" for
"bundle-src", "bundle-bin", "populate-src".

On Thu, Feb 14, 2008 at 4:01 PM, Alexei Fedotov
<alexei.fedotov@gmail.com> wrote:
> I love unification. From the other side why choose "build-all",
>  "populate-source", "make-snapshot"? Why not "build",
>  "populate"/"checkout", "snapshot"/"bundle"?
>
>
>
>  On Thu, Feb 14, 2008 at 3:51 PM, Tim Ellison <t.p.ellison@gmail.com> wrote:
>  > Nathan Beyer wrote:
>  >  > Does anyone object to normalizing the names of the Ant targets? The
>  >  > mixed use of '-' and '_' is starting to push me over the edge. As an
>  >  > example, here's the targets available in the top-level of the
>  >  > federated build.
>  >  >
>  >  >  build-all        build complete implementation
>  >  >  bundle_src       assemble source snapshot
>  >  >  default          setup and build complete implementation
>  >  >  make-snapshot    setup and build complete src + binaries set
>  >  >  populate_source  checkout the class library and VM source trees
>  >  >  reset            removes vm and classlib dirs and resets
>  >  >
>  >  > I'd like to just use '-' across the board.
>  >
>  >  LOL +1
>  >
>  >
>  >  > We can maintain the previous targets for a while via redirects and put
>  >  > in some deprecation statements.
>  >
>  >  nah, just dump them :-)
>  >
>  >  Regards,
>  >  Tim
>  >
>
>
>
>  --
>  With best regards,
>  Alexei
>



-- 
With best regards,
Alexei

Mime
View raw message