harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ilya Berezhniuk" <ilya.berezhn...@gmail.com>
Subject Re: [eut][regressions] EUT regressions on Linux x86
Date Thu, 13 Dec 2007 14:25:27 GMT
I think I've found why this suite hangs.

Last 9 "BrowserTest"s work for a long time, then message box appears
and waits for "OK" button to be pressed.
Message box says "The operation timed out when attempting to contact
www.google.com."

This problem is reproducible on Harmony snapshot, HDK build, and also
on Sun and BEA.
I guess something wrong with network/proxy settings on the host, or
probably something wrong with Google :)


Thanks,
Ilya.

2007/12/13, Ilya Berezhniuk <ilya.berezhniuk@gmail.com>:
> I've reproduced crash in 'swt' suite on Linux/x86.
> It's actually a hangup, so suite is killed by timeout.
>
> I'll try to find a cause (or at least hanging test) using runs from Eclipse GUI.
> Else I'll try to find affecting commit introduced this hangup.
>
> Thanks,
> Ilya.
>
> 2007/12/13, Vladimir Beliaev <vladimir.k.beliaev@gmail.com>:
> > According to report at
> > http://people.apache.org/~smishura/r603433/Linux_x86/eut33/ there are
> > regressions for EUT3.3 on Linux x86.
> >
> > I've checked 6 failures at org.eclispe.jdt.ui.tests.AutomatedSuite - they
> > are reproducible. There are just few commits between passed & failed
> > revisions, and one of them is my patch for EUT BTI which redefined TMP/HOME
> > settings. I continue checking - it may turn out that these 6 tests work with
> > related environment variable incorrectly (so the tests may be invalid).
> >
> > Also I've reproduced 'swt' crash on Linux x86. Checking this regression is a
> > separate subject.
> >
> > Thanks
> > Vladimir
> >
>

Mime
View raw message