harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksey Shipilev" <aleksey.shipi...@gmail.com>
Subject Re: [build] Release build is broken
Date Wed, 28 Nov 2007 14:53:45 GMT
Fixed, no build problems.

On Nov 28, 2007 5:52 PM, Mikhail Fursov <mike.fursov@gmail.com> wrote:
> Please check r599017
>
>
> On Nov 28, 2007 8:38 PM, Mikhail Fursov <mike.fursov@gmail.com> wrote:
> > I'll check and commit if it's still not fixed.
> >
> >
> > On Nov 28, 2007 8:35 PM, Aleksey Shipilev <aleksey.shipilev@gmail.com> wrote:
> > > Hi all,
> > >
> > > I have tried to build r599011 on Windows/ia32 and failed with this error:
> > >
> > > ============================== cut ==================================
> > >    626  build.native.init:
> > >    627       [echo] ## Building native of 'vm.jitrino'
> > >    628
> > >    629  build.native.c:
> > >    630         [cc] 0 total files to be compiled.
> > >    631
> > >    632  build.native.cpp:
> > >    633         [cc] Starting dependency analysis for 151 files.
> > >    634         [cc] 151 files are up to date.
> > >    635         [cc] 0 files to be recompiled from dependency analysis.
> > >    636         [cc] 1 total files to be compiled.
> > >        [cc] cl : Command line warning D4025 : overriding '/W3' with '/W4'
> > >    637         [cc] rt.cpp
> > >    638         [cc]
> > > C:\users\shade\Harmony\trunk\working_vm\vm\jitrino\src\jet\rt.cpp(407)
> > > : error C2065: 'meth_start' :
> > >  undeclared identifier
> > >
> > > BUILD FAILED
> > > C:\users\shade\Harmony\trunk\working_vm\build\make\build.xml:581: The
> > > following error occurred while executing this line
> > > :
> > > C:\users\shade\Harmony\trunk\working_vm\build\make\build.xml:588: The
> > > following error occurred while executing this line
> > > :
> > > C:\users\shade\Harmony\trunk\working_vm\build\make\build_component.xml:74:
> > > The following error occurred while executing
> > > this line:
> > > C:\users\shade\Harmony\trunk\working_vm\build\make\targets\build.native.xml:107:
> > > cl failed with return code 2
> > >
> > > Total time: 18 seconds
> > > ============================== cut ==================================
> > >
> > > I had a quick look into the sources and my minor change:
> > >
> > > Index: vm/jitrino/src/jet/rt.cpp
> > > ===================================================================
> > > --- vm/jitrino/src/jet/rt.cpp   (revision 599011)
> > > +++ vm/jitrino/src/jet/rt.cpp   (working copy)
> > > @@ -397,8 +397,9 @@
> > >
> > >      void *** pip = (void***)((char*)context + ip_off);
> > >      char * where = (char*)**pip;
> > > +
> > > +    char * meth_start = infoBlock.get_code_start();
> > >  #ifdef _DEBUG
> > > -    char * meth_start = infoBlock.get_code_start();
> > >      unsigned meth_len = infoBlock.get_code_len();
> > >      assert(meth_start <= where);
> > >      assert(where < meth_start + meth_len);
> > >
> > > ...solves the problem. Could JIT gurus review this fix and commit it?
> > >
> > > Thanks,
> > > Aleksey,
> > > ESSD, Intel.
> > >
> >
> >
> >
> > --
> > Mikhail Fursov
> >
>
>
>
> --
> Mikhail Fursov
>

Mime
View raw message