harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nadya Morozova" <nad.moroz...@googlemail.com>
Subject Re: [site] update Quick Help for Contributors (the building instructions)
Date Wed, 03 Oct 2007 15:55:00 GMT
Alexei,
thanks for clarification.

i think it's ok to make the following statement in the doc:

- Apache Ant 1.6.5 (a higher version can be used only for class libraries)

On 10/3/07, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
>
> > > "Ant 1.6.5 or higher" to "Ant 1.6.5"?  Is there a problem with later
> > > versions of Ant?
> > Yes, Alexei Fedotov mentioned to me that higher versions are not
> currently
> > supported. I suggest asking again to reconfirm.
>
> Well, in general Ant 1.7 is ok if you are working on classlib only.
> I'm using it currently in my daily work for example. However, if you
> are committing something to DRLVM workspace you need to run DRLVM
> acceptance tests. And it is a problem with ant 1.7 - IIRC I
> encountered some strange errors while trying to run it on recent
> versions of ant. Looks like the current DRLVM build system is closely
> connected with ant 1.6.5 .
>
> Regards,
> Alexei
>
> 2007/10/3, Nadya Morozova <nad.morozova@googlemail.com>:
> > On 10/3/07, Sian January <sianjanuary@googlemail.com> wrote:
> > >
> > > Hi Nadya,
> > >
> > > Your patch looks good - it definitely makes sense to change the tense
> for
> > > that page, it reads a lot more easily now.  It's really helpful to
> have
> > > numbered sections too.
> >
> >
> >  If you like it, I can commit and we shall see how people react.
> >
> > Just a small point, but I wondered why you changed
> > > "Ant 1.6.5 or higher" to "Ant 1.6.5"?  Is there a problem with later
> > > versions of Ant?
> >
> >
> > Yes, Alexei Fedotov mentioned to me that higher versions are not
> currently
> > supported. I suggest asking again to reconfirm.
> >
> > I think we do still need Visual Studio 2003 (which includes the compiler
> so
> > > you don't need another one) but I'm happy to be corrected on this.
> >
> >
> > Ok, so additional compilers are optional. Let's check on the list and
> then
> > change the page's wording.
> >
> > Thanks,
> > >
> > > Sian
> > >
> > >
> > > On 03/10/2007, Nadya Morozova <nad.morozova@googlemail.com> wrote:
> > > >
> > > > Hi,
> > > > I decided to update the Quick Help for Contributors page [1] and
> posted
> > > a
> > > > patch to JIRA 4893 [2]. I only changed the wording in some places to
> > > > switch
> > > > accents. you're welcome to review the patch and submit your
> comments.
> > > >
> > > > if somebody could read / test the latest Quick Help page and let me
> know
> > > > if
> > > > there are any technical discrepancies, i'd be very thankful. i guess
> the
> > > > prerequisites part may be out of date or incomplete. for example: do
> we
> > > > actually need MS VS 2003? Do we need the Pro version only, or can
> users
> > > > download a free Express Edition and be done? What about compilers?
> Will
> > > > the
> > > > MS VS built-in compiler be enough or do we need an external
> compiler,
> > > like
> > > > Intel's 9.0?
> > > >
> > > > [1] http://harmony.apache.org/quickhelp_contributors.html
> > > > [2] https://issues.apache.org/jira/browse/HARMONY-4893
>



-- 
Cheers,
Nadya

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message