harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ilya Berezhniuk" <ilya.berezhn...@gmail.com>
Subject Re: [classlib][icu] Bringing ICU level up to 3.8
Date Mon, 08 Oct 2007 14:14:09 GMT
> > BTW, We keep some resource bundle classes in luni, such as Locale and
> > Currency, which used by luni and text module. These data are aslo
> > included in icu, I suggest to remove this overlap, just keep one of
> > them.
> Agreed - if we can use the ICU version of these resources then IMHO we
> should do it.

There is similar place in java/nio/charset/Charset: when
availableCharsets method prepares charsets it concatenates ICU
charsets with a set of internal charsets returned by
org.apache.harmony.niochar.CharsetProviderImpl class. But I'm not
quite sure that it should be fixed; probably there were some reasons
for such approach.


View raw message