harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Zakharov" <alexei.zakha...@gmail.com>
Subject Re: [site] update Quick Help for Contributors (the building instructions)
Date Sun, 07 Oct 2007 17:19:29 GMT
> could you please also clarify the MS Visual Studio dependency? Do we only
> only support 2003, professional? What about express edition, about 2005?

AFAIK we support VS 2003 on Win32 and VS 2005 on Win64. And that's that.
However, my information can be outdated already.

Alexei

2007/10/4, Nadya Morozova <nad.morozova@googlemail.com>:
> Ok, thanks.
> I re-added the "or later" amendment to the Apache Ant required version. I
> also changed the wording of compilers for windows slightly (because MS VS
> built-in compiler should be enough, other compilers appear optional).
>
> could you please also clarify the MS Visual Studio dependency? Do we only
> only support 2003, professional? What about express edition, about 2005?
>
> I'd also rely on somebody from DRLVM engineers to submit a JIRA for Ant
> 1.6.5 dependency with all required detail.
>
> cheers, Nadya
>
> On 10/4/07, Mark Hindess <mark.hindess@googlemail.com> wrote:
> >
> >
> > On 4 October 2007 at 11:51, "Alexey Varlamov" <alexey.v.varlamov@gmail.com>
> > wrote:
> > > 2007/10/3, Nadya Morozova <nad.morozova@googlemail.com>:
> > > > Alexei,
> > > > thanks for clarification.
> > > >
> > > > i think it's ok to make the following statement in the doc:
> > > >
> > > > - Apache Ant 1.6.5 (a higher version can be used only for class
> > libraries)
> > >
> > > I'd suggest we file a JIRA against DRLVM if there is a problem
> > > (still), and leave this as "Ant 1.6.5 or higher". I don't think we
> > > need to jam this intro with transient issues (btw it could encourage
> > > someone to ask on dev@ ;) ).
> >
> > +1, this issue will occur more and more as ant 1.6.5 becomes more dated
> > so we might as well resolve it now (well, after m3 ;-).
> >
> > -Mark.

Mime
View raw message